Bug 1019791 - slock does not have suid applied
slock does not have suid applied
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: slock (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Šabata
Branislav Blaškovič
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 08:20 EDT by Branislav Blaškovič
Modified: 2013-11-28 03:01 EST (History)
1 user (show)

See Also:
Fixed In Version: slock-1.1-5.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-28 03:01:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Branislav Blaškovič 2013-10-16 08:20:19 EDT
Description of problem:

slock is not installed with o+s permissions. This causes that it cannot read shadow file and fail to start.


Version-Release number of selected component (if applicable):
slock-1.1-4.fc20.x86_64

Steps to Reproduce:
1. start slock

Actual results:
$ slock
slock: cannot retrieve shadow entry (make sure to suid or sgid slock)

Expected results:
slock successfuly locks the screen

Additional info:
This works great on f19.

Modes of /usr/bin/slock:
slock-1.1-3.fc19.x86_64.rpm: -rwsr-xr-x (4755)
slock-1.1-4.fc20.x86_64.rpm: -rwxr-xr-x (0755)
Comment 1 Branislav Blaškovič 2013-10-16 08:33:32 EDT
As a workaround you can run this under root:

# chmod u+s /usr/bin/slock
Comment 2 Petr Šabata 2013-10-16 23:00:11 EDT
This is already done in the Makefile and I can even see it happen in the build.log.  Still, you're right -- the permissions are incorrect.
Comment 3 Petr Šabata 2013-10-16 23:19:14 EDT
This seems to be an intentional mock constraint now.
Setting the bits with %attr solves the issue.
Comment 4 Fedora Update System 2013-10-16 23:38:53 EDT
slock-1.1-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/slock-1.1-5.fc20
Comment 5 Branislav Blaškovič 2013-10-17 09:13:05 EDT
Thank you! 

I built rpm from repo.

$ rpm -q slock
slock-1.1-5.fc20.x86_64

$ ls -l /usr/bin/slock 
-rwsr-xr-x. 1 root root 15344 Oct 17 15:11 /usr/bin/slock

slock works great now.
Comment 6 Branislav Blaškovič 2013-10-18 08:32:15 EDT
Version from updates-testing works great too.
Comment 7 Fedora Update System 2013-11-10 01:43:52 EST
slock-1.1-5.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.