Bug 1019797 - Remote-viewer received SIGABRT after several copy-paste of big amount of text
Remote-viewer received SIGABRT after several copy-paste of big amount of text
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Marc-Andre Lureau
Desktop QE
:
Depends On: 1017250
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 08:31 EDT by Vaclav Ehrlich
Modified: 2016-10-04 00:02 EDT (History)
8 users (show)

See Also:
Fixed In Version: spice-gtk-0.22-1.el6
Doc Type: Bug Fix
Doc Text:
Previously, virt-viewer was unable to handle large copy and paste operations. If a very large amount of text was copied, then mingw-virt-viewer displayed a failure to allocate memory error. After fixing this bug, up to 100 MB of data can be copied and pasted.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 02:46:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1487 normal SHIPPED_LIVE spice-gtk bug fix and enhancement update 2014-10-13 21:28:31 EDT

  None (edit)
Description Vaclav Ehrlich 2013-10-16 08:31:32 EDT
Description of problem:
remote-viewer crash because could not allocate memory for big amount of data.

Version-Release number of selected component (if applicable):
virt-viewer 0.5.6-8
spice=gtk 0.20-9
spice-vdagent 0.14.0-2


Steps to Reproduce:
1.Connect to guest by remote-viewer from client
2.Open text file in client VM and copy whole text (more than 100Mb) into clipboard
3.Open text editor in guest VM and paste text from clipboard

Actual results:
remote-viewer crashes

Expected results:
remote-viewer does not crash

Additional info:

gdb:
GLib-ERROR **: gmem.c:170: failed to allocate 155676817 bytes
aborting...
Program received signal SIGABRT, Aborted.


(gdb) backtrace
#0  0x0000003a81e32925 in raise (sig=6)
   at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
Cannot access memory at address 0x7fffffffcad8


guest: Win7 64
client: Rhel6.5 64
host: RHEL 6.5 64
Comment 1 Marc-Andre Lureau 2013-10-16 08:36:30 EDT
See also bug 1017250

in general, crash on OOM is the expected behaviour, and it's fine for the client.
Comment 3 RHEL Product and Program Management 2013-10-19 09:24:34 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 Marc-Andre Lureau 2014-03-07 10:47:44 EST
following dep bug status
Comment 7 errata-xmlrpc 2014-10-14 02:46:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1487.html

Note You need to log in before you can comment on or make changes to this bug.