Bug 1019803 - [VDSM] ConnectStoragePool fails with: StoragePoolWrongMaster: Wrong Master domain or its version
[VDSM] ConnectStoragePool fails with: StoragePoolWrongMaster: Wrong Master do...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.5.0
Assigned To: Allon Mureinik
Aharon Canan
storage
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 08:46 EDT by Raz Tamir
Modified: 2016-02-10 14:35 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-09 15:29:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm log (12.21 MB, text/plain)
2013-10-16 08:46 EDT, Raz Tamir
no flags Details
engine log (4.48 MB, text/plain)
2013-10-16 08:47 EDT, Raz Tamir
no flags Details

  None (edit)
Description Raz Tamir 2013-10-16 08:46:02 EDT
Created attachment 812902 [details]
vdsm log

Description of problem:

When trying to remove a DC, after maintenance the storage domain attached to it , no error message displayed but in the events log (web portal) there is a tuple that syas "Failed to remove Data Center". The situation is that you can not:
remove the DC, activate the attached domain.
also, the DC's status is : non responsive.

from the vdsm.log:
StoragePoolWrongMaster: Wrong Master domain or its version


Version-Release number of selected component (if applicable):


How reproducible:
rhevm-3.3.0-0.24.master.el6ev.noarch

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Raz Tamir 2013-10-16 08:47:23 EDT
Created attachment 812903 [details]
engine log
Comment 2 Maor 2013-12-25 09:04:35 EST
From the log it seems that DeactivateStorageDomain was called several time.
DeactivateStorageDomain increases the master version and later send it to VDSM.
Recently there was a fix in that area of code introduced in commit 87902a0a08a4ceffcb0bdb9d45ec4a01f8b86a7e which I believe might fix this issue, but since this bug does not reproduce consistently and there are no reproduce steps, I can't be sure.

Liron, what do you think? Is your patch might fix that?
Comment 3 Ayal Baron 2013-12-26 04:39:21 EST
Aharon, reproduction steps?
Comment 4 Raz Tamir 2013-12-29 08:44:50 EST
No actual steps were taken that cause this bug.
also tried to debug this issue to figure out what cause the problem but i didn't see anything unusual

Note You need to log in before you can comment on or make changes to this bug.