Bug 1019868 - [RFE] Please include PAM authentication plugin for MariaDB
[RFE] Please include PAM authentication plugin for MariaDB
Status: CLOSED ERRATA
Product: Red Hat Software Collections
Classification: Red Hat
Component: mariadb (Show other bugs)
mariadb55
All Linux
medium Severity medium
: ---
: 1.1
Assigned To: Honza Horak
Branislav Blaškovič
: FutureFeature
Depends On:
Blocks: 1019945
  Show dependency treegraph
 
Reported: 2013-10-16 10:21 EDT by Julio Entrena Perez
Modified: 2014-06-04 03:19 EDT (History)
6 users (show)

See Also:
Fixed In Version: mariadb-5.5.33a-2.el7
Doc Type: Enhancement
Doc Text:
The Pluggable Authentication Modules (PAM) plug-in has been added to the mariadb55 Software Collection. PAM allows a system to set up authentication policies without the need to recompile programs to handle authentication. The plug-in also includes a number of authentication features, such as enforcing password expiration.
Story Points: ---
Clone Of:
: 1019945 (view as bug list)
Environment:
Last Closed: 2014-06-04 03:19:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 533853 None None None Never

  None (edit)
Description Julio Entrena Perez 2013-10-16 10:21:46 EDT
Description of problem:
PAM Authentication Plugin is not currently shipped in MariaDB 55 SCL packages.

Customer wants to use PAM to enforce password expiration so users have to change their passwords on a regular basis (required for PCI compliance).

Version-Release number of selected component (if applicable):
mariadb55-mariadb 5.5.32-1.el6
mariadb55 1-7.el6

How reproducible:
Always.

Steps to Reproduce:
1. Install MariaDB 5.5 SCL packages.
2.
3.

Actual results:
/opt/rh/mariadb55/root/usr/lib64/mysql/plugin/auth_pam.so is missing.

Expected results:
/opt/rh/mariadb55/root/usr/lib64/mysql/plugin/auth_pam.so is provided.

Additional info:
Rebuilding packages with 'pam-devel' packages installed solves it.
Comment 1 Honza Horak 2013-10-16 12:38:10 EDT
This seems to be quite easy; only pam-devel should be added to the BuildRequires, so providing dev_ack.
Comment 6 errata-xmlrpc 2014-06-04 03:19:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0614.html

Note You need to log in before you can comment on or make changes to this bug.