Bug 101987 - Some letters on Windows drives are wrong
Summary: Some letters on Windows drives are wrong
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel   
(Show other bugs)
Version: beta1
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-08 16:40 UTC by Henrik Lind
Modified: 2015-01-04 22:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-26 01:37:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Henrik Lind 2003-08-08 16:40:11 UTC
Description of problem:

Some letters on Windows drives are wrong.

I made a file in WinXP called 'TEST æøå ÃÃà üöä ÃÃà é.txt' and in Linux the
files comes out like 'TEST ??? ??? ??? ??? ?.txt'

I'm writing this from the same linux box and as you can see, the letters works well.

Steps to Reproduce:
1. In Windows make a file called 'TEST æøå ÃÃà üöä ÃÃà é.txt' on a FAT32 drive
2. Reboot the PC into RedHat Linux.
3. Open a terminal or use Nautilus and check the file name on the FAT32 drive
    
Actual results:

TEST ??? ??? ??? ??? ?.txt

Expected results:

TEST æøå ÃÃà üöä ÃÃà é.txt

Additional info:

If I make the same filename in Linux it works fine (not tested on the FAT32 drive).
I'm using a Danish keyborad

Comment 1 Tim Waugh 2003-08-08 16:42:05 UTC
Nothing to do with bash.

Comment 2 Dave Jones 2003-08-08 16:53:07 UTC
Try inserting one of the codepage modules (modprobe nls_cp850 for example).
or possible nls_iso8859-15


Comment 3 Henrik Lind 2003-08-08 17:22:00 UTC
And How do I do that?
as ROOT I don't have a command called modprobe.

Comment 4 Michael K. Johnson 2003-08-08 19:30:57 UTC
/sbin/modprobe
use "su -" not "su" if you want to access commands in /sbin or /usr/sbin
without having to type the full pathname.

Comment 5 Henrik Lind 2003-08-08 20:27:51 UTC
Just tried to do 'modprobe nls_cp850' and 'modprobe nls_iso8859-15' and still
the same.




Comment 6 Kai Thomsen 2003-08-14 16:43:18 UTC
Find the line corresponding to your FAT32 partition in /etc/fstab, and add 
`iocharset=utf8' as a mount option (third field to the right).

Comment 7 Henrik Lind 2003-08-15 05:08:03 UTC
Ok, I changed the fstab file to this :

/dev/hdb2    /win_data     vfat,iocharset=utf8    defaults      0 0

Still the same, it did not fix it :(


Comment 8 Kai Thomsen 2003-08-15 10:47:33 UTC
No, it should be as follows:

/dev/hdb2    /win_data     vfat    defaults,iocharset=utf8      0 0

Comment 9 Henrik Lind 2003-08-15 15:50:56 UTC
That seemed to do the trick.
I now have the correct names in terminal and in most other programs (not Xine's
file selector).

I guess the installer did not know/guess that I has a Danish FAT32 drive?


Comment 10 Mikko Paananen 2003-10-28 15:47:30 UTC
Duplicates: #79396, #107834, #107935.

This problem has been reported least three times during severn beta cycle.

#79396 is on "make cambrigde better"
#107834 has alternative fix.



Note You need to log in before you can comment on or make changes to this bug.