Bug 1019872 - [RHEL6] rpm plug-in default verify list verifies too much
[RHEL6] rpm plug-in default verify list verifies too much
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sos (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryn M. Reeves
David Kutálek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 10:26 EDT by Bryn M. Reeves
Modified: 2014-10-14 03:22 EDT (History)
6 users (show)

See Also:
Fixed In Version: sos-2.2-57.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of: 1019863
Environment:
Last Closed: 2014-10-14 03:22:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryn M. Reeves 2013-10-16 10:26:30 EDT
+++ This bug was initially created as a clone of Bug #1019863 +++

Description of problem:
The rpm plug-in now runs "rpm -V" against a restricted list of packages by default:

commit f9c24a2e75a81965dc82b528d73d71582fa68803
Author: Bryn M. Reeves <bmr@redhat.com>
Date:   Tue Aug 13 22:15:35 2013 +0100

    Add restricted rpm verify
    
    Backport of commit 1b3fc3f.
    
    Add a default call to rpm -V/--verify for a targeted subset of
    packages. This greatly reduces the time taken relative to rpm -Va
    while still capturing important diagnostic information.
    
    In future this capability could be made a feature of the
    PackageManager class interface and available to all ports/modules.
    
    Signed-off-by: Bryn M. Reeves <bmr@redhat.com>


The original verify_list is:

    verify_list = [
        'kernel', 'glibc', 'initscripts',
        'pam_.*',
        'java.*', 'perl.*',
        'rpm', 'yum',
        'spacewalk.*'
    ]

This can lead to very long runtimes as it will match package names like "kernel-devel", "kernel-debuginfo" etc. For the kernel deuginfo and java devel packages in particular this can add several minutes to the time taken for a default sosreport run.

Version-Release number of selected component (if applicable):
sos-2.2-43.el6

How reproducible:
100%

Steps to Reproduce:
1. Install a few kernel-debuginfo packages, or java-*-openjdk-devel
2. # time sosreport


Actual results:
Must longer runtime

Expected results:
sos should keep the time spent on default package verification to a minimum and only verify devel and debuginfo packages if enabled via the rpm.rpmva option.

Additional info:
Comment 3 Bryn M. Reeves 2014-06-23 09:31:24 EDT
commit 7f1563b9c61a6f219e86e957b4363eeb1812b4ad
Author: Bryn M. Reeves <bmr@redhat.com>
Date:   Mon Jun 23 16:08:04 2014 +0100

    [rpm] reduce number of calls to rpm
    
    Fixes #300.
    
    Signed-off-by: Bryn M. Reeves <bmr@redhat.com>
    
    Conflicts:
    
        sos/plugins/rpm.py

commit b3680a6003916fdee8fb2bb6eb61462f1368bb9f
Author: Bryn M. Reeves <bmr@redhat.com>
Date:   Mon Jun 23 16:04:21 2014 +0100

    Verify fewer packages in rpm plug-in
    
    The current default set of packages to verify includes debuginfo
    and devel subpackages. Filter these out to reduce the time spent
    running rpm -V.
    
    Signed-off-by: Bryn M. Reeves <bmr@redhat.com>
    
    Conflicts:
    
        sos/plugins/rpm.py
Comment 6 errata-xmlrpc 2014-10-14 03:22:30 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1528.html

Note You need to log in before you can comment on or make changes to this bug.