Bug 1019949 - Unable to make an OpenVPN connection via NetworkManager
Unable to make an OpenVPN connection via NetworkManager
Status: CLOSED DUPLICATE of bug 1018317
Product: Fedora
Classification: Fedora
Component: NetworkManager-openvpn (Show other bugs)
20
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 12:44 EDT by Jared Smith
Modified: 2013-10-16 12:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-16 12:53:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jared Smith 2013-10-16 12:44:53 EDT
Description of problem:

I installed the Alpha of F20, then attempted to connect to my work VPN.  (For the record, I simply copied the profile from /etc/NetworkManager/system-connections/ on my F19 installation to the F20 installation.


Version-Release number of selected component (if applicable):

NetworkManager-openvpn-0.9.8.2-3.fc20.x86_64
NetworkManager-0.9.9.0-14.git20131003.fc20.x86_64

How reproducible:

Very. :-)

Steps to Reproduce:
1.  Copy a working /etc/NetworkManager/system-connections/ profile from a working F19 installation
2. Try to connect
3. See that it fails with an unspecified error

Actual results:

Failure (see sample logs below)

Expected results:

I would expect it to connect to the remote VPN

Additional info:

Here are the journal logs from the F20 system when attempting to connect:

Oct 16 12:35:17 hockey NetworkManager[15407]: <info> Starting VPN service 'openvpn'...
Oct 16 12:35:17 hockey NetworkManager[15407]: <info> VPN service 'openvpn' started (org.freedesktop.NetworkManager.openvpn), PID 4971
Oct 16 12:35:17 hockey NetworkManager[15407]: <info> VPN service 'openvpn' appeared; activating connections
Oct 16 12:35:17 hockey NetworkManager[15407]: <info> VPN plugin state changed: init (1)
Oct 16 12:35:17 hockey NetworkManager[15407]: <info> VPN plugin state changed: starting (3)
Oct 16 12:35:17 hockey NetworkManager[15407]: ** Message: openvpn started with pid 4975
Oct 16 12:35:17 hockey NetworkManager[15407]: <info> VPN connection 'Bluehost' (Connect) reply received.
Oct 16 12:35:17 hockey NetworkManager[15407]: Wed Oct 16 12:35:17 2013 DEPRECATED OPTION: --tls-remote, please update your configuration
Oct 16 12:35:17 hockey nm-openvpn[4975]: OpenVPN 2.3.2 x86_64-redhat-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [PKCS11] [eurephia] [MH] [IPv6] built on Sep 12 2013
Oct 16 12:35:17 hockey nm-openvpn[4975]: NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Oct 16 12:35:17 hockey nm-openvpn[4975]: Control Channel Authentication: using '/home/jsmith/.cert/ta.key' as a OpenVPN static key file
Oct 16 12:35:17 hockey nm-openvpn[4975]: Attempting to establish TCP connection with [AF_INET]74.220.198.228:1194 [nonblock]
Oct 16 12:35:19 hockey nm-openvpn[4975]: TCP connection established with [AF_INET]74.220.198.228:1194
Oct 16 12:35:19 hockey nm-openvpn[4975]: TCPv4_CLIENT link local: [undef]
Oct 16 12:35:19 hockey nm-openvpn[4975]: TCPv4_CLIENT link remote: [AF_INET]74.220.198.228:1194
Oct 16 12:35:37 hockey nm-openvpn[4975]: [vpn.bluehost.com] Peer Connection Initiated with [AF_INET]74.220.198.228:1194
Oct 16 12:35:43 hockey nm-openvpn[4975]: TUN/TAP device tun0 opened
Oct 16 12:35:43 hockey nm-openvpn[4975]: /usr/libexec/nm-openvpn-service-openvpn-helper tun0 1500 1560 10.50.11.142 10.50.11.141 init
Oct 16 12:35:43 hockey NetworkManager[15407]: <info> (tun0): carrier is OFF
Oct 16 12:35:43 hockey NetworkManager[15407]: <info> (tun0): new Tun device (driver: 'unknown' ifindex: 23)
Oct 16 12:35:43 hockey NetworkManager[15407]: <info> (tun0): exported as /org/freedesktop/NetworkManager/Devices/6
Oct 16 12:35:43 hockey NetworkManager[15407]: <info> (tun0): No existing connection detected.
Oct 16 12:35:43 hockey NetworkManager[15407]: <info> VPN connection 'Bluehost' (IP4 Config Get) reply received from old-style plugin.
Oct 16 12:35:43 hockey NetworkManager[15407]: <info> VPN Gateway: 74.220.198.228
Oct 16 12:35:43 hockey NetworkManager[15407]: <info> Tunnel Device: tun0
Oct 16 12:35:43 hockey NetworkManager[15407]: <info> IPv4 configuration:
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Internal Gateway: 10.50.11.141
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Internal Address: 10.50.11.142
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Internal Prefix: 32
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Internal Point-to-Point Address: 10.50.11.141
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Maximum Segment Size (MSS): 0
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 10.0.96.0/20   Next Hop: 10.0.96.0
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 10.0.80.0/20   Next Hop: 10.0.80.0
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 69.89.16.0/20   Next Hop: 69.89.16.0
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 67.222.32.0/19   Next Hop: 67.222.32.0
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 66.147.240.0/20   Next Hop: 66.147.240.0
Oct 16 12:35:43 hockey nm-openvpn[4975]: Initialization Sequence Completed
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 70.40.192.0/19   Next Hop: 70.40.192.0
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 67.20.64.0/18   Next Hop: 67.20.64.0
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 69.195.64.0/18   Next Hop: 69.195.64.0
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 173.254.0.0/17   Next Hop: 173.254.0.0
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 50.87.0.0/16   Next Hop: 50.87.0.0
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 74.220.192.0/22   Next Hop: 74.220.192.0
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 74.220.196.0/23   Next Hop: 74.220.196.0
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 74.220.198.0/28   Next Hop: 74.220.198.0
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 74.220.198.16/29   Next Hop: 74.220.198.16
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 74.220.198.32/27   Next Hop: 74.220.198.32
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 74.220.198.64/26   Next Hop: 74.220.198.64
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 74.220.198.128/26   Next Hop: 74.220.198.128
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 74.220.198.192/27   Next Hop: 74.220.198.192
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 74.220.198.240/28   Next Hop: 74.220.198.240
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 74.220.199.0/24   Next Hop: 74.220.199.0
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 74.220.200.0/21   Next Hop: 74.220.200.0
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 74.220.208.0/20   Next Hop: 74.220.208.0
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 10.2.0.0/16   Next Hop: 10.2.0.0
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 10.20.30.0/24   Next Hop: 10.20.30.0
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 10.101.0.0/16   Next Hop: 10.101.0.0
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 10.102.0.0/16   Next Hop: 10.102.0.0
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 67.225.149.187/32   Next Hop: 67.225.149.187
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 10.1.1.117/32   Next Hop: 10.1.1.117
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 10.1.1.119/32   Next Hop: 10.1.1.119
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 10.1.1.160/32   Next Hop: 10.1.1.160
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 10.1.52.0/24   Next Hop: 10.1.52.0
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 162.144.8.64/27   Next Hop: 162.144.8.64
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 10.100.114.0/24   Next Hop: 10.100.114.0
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 10.100.2.0/24   Next Hop: 10.100.2.0
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 172.31.186.0/24   Next Hop: 172.31.186.0
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 10.50.0.1/32   Next Hop: 10.50.0.1
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 74.220.198.24/29   Next Hop: 74.220.198.24
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Static Route: 65.254.224.53/32   Next Hop: 65.254.224.53
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Forbid Default Route: yes
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   Internal DNS: 10.0.100.13
Oct 16 12:35:43 hockey NetworkManager[15407]: <info>   DNS Domain: '(none)'
Oct 16 12:35:43 hockey NetworkManager[15407]: <info> No IPv6 configuration
Oct 16 12:35:43 hockey NetworkManager[15407]: <info> (tun0): link connected
Oct 16 12:35:43 hockey NetworkManager[15407]: <error> [1381941343.705350] [platform/nm-linux-platform.c:1109] add_object(): Netlink error: Unspecific failure
Oct 16 12:35:43 hockey NetworkManager[15407]: <warn> VPN connection 'Bluehost' did not receive valid IP config information.
Oct 16 12:35:43 hockey NetworkManager[15407]: ** Message: Terminated openvpn daemon with PID 4975.
Oct 16 12:35:43 hockey avahi-daemon[2281]: Withdrawing workstation service for tun0.
Oct 16 12:35:43 hockey NetworkManager[15407]: refresh_object: assertion 'kernel_object' failed
Oct 16 12:35:43 hockey NetworkManager[15407]: <error> [1381941343.714178] [platform/nm-linux-platform.c:1142] delete_object(): Netlink error: No such device
Oct 16 12:35:43 hockey nm-openvpn[4975]: SIGTERM[hard,] received, process exiting
Oct 16 12:35:43 hockey NetworkManager[15407]: <warn> (tun0): failed to get device's ifindex
Oct 16 12:35:43 hockey gnome-session[17773]: Gjs-Message: JS LOG: Removing a network device that was not added
Oct 16 12:35:49 hockey NetworkManager[15407]: <info> VPN service 'openvpn' disappeared

In particular, notice the "Unspecific failure" and "did not receive valid IP config information" messages.
Comment 1 Jared Smith 2013-10-16 12:46:49 EDT
Looks like this *might* be related to RHBZ#1013200, but I can't be sure, as their bug report doesn't include any logs.  Just adding that information here in case it's relevant.
Comment 2 Dan Williams 2013-10-16 12:53:29 EDT

*** This bug has been marked as a duplicate of bug 1018317 ***

Note You need to log in before you can comment on or make changes to this bug.