Bug 1019958 - RFE: geo-replication should check for and report identically named files/dirs on the slave [NEEDINFO]
RFE: geo-replication should check for and report identically named files/dirs...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: doc-Administration_Guide (Show other bugs)
2.1
All Linux
high Severity high
: ---
: ---
Assigned To: Divya
Vijaykumar Koppad
: FutureFeature, ZStream
Depends On: 1019954
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 13:10 EDT by Kevin Clevenger
Modified: 2014-08-24 20:50 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-09 11:48:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
asriram: needinfo? (mohit_anchlia)


Attachments (Terms of Use)

  None (edit)
Comment 2 Amar Tumballi 2013-10-30 07:48:04 EDT
Can this be fine to link this with bug 1019954 which treats this case as a skip, and that would lead admin to query logs to figure out which all files are not synced.
Comment 6 Nagaprasad Sathyanarayana 2013-11-05 07:44:55 EST
Looks like there is no further code fix required as customer is okay with the existing behavior as described by Amar in comment#4. Since Kevin has checked with customer and given a go, moving it to QE to confirm that the behavior is as described in comment #4.
Comment 7 Amar Tumballi 2013-11-07 13:08:55 EST
Msg from QE:

This is error message you get if the slave already has data,

"slave-node::slave is not empty. Please delete existing files in slave-node::slave and retry, or use force to continue without deleting the existing files.
geo-replication command failed
"

Marking this bug for documentation (also changing the component).
Comment 9 Anjana Suparna Sriram 2013-11-11 04:28:57 EST
Hi Mohit,

Could you review the doc (link in Comment 8) and let us know if it addresses your concern?

Regards,
Anjana
Comment 10 M S Vishwanath Bhat 2013-11-25 07:46:51 EST
When a user tries to create a geo-rep session with the slave which already has data, geo-rep create throws an error like the one below.


[root@pythagoras ]# gluster v geo master euclid::slave create push-pem
euclid::slave is not empty. Please delete existing files in euclid::slave and retry, or use force to continue without deleting the existing files.
geo-replication command failed


Since this is documented in http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_Storage/2.1/html/Administration_Guide/chap-User_Guide-Geo_Rep-Starting.html#chap-User_Guide-Geo_Rep-Starting-Start I am moving this bug to verified.

If there is something else needed, please open a new bug.

Note You need to log in before you can comment on or make changes to this bug.