This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1019967 - Undeploying DT gov and DT Goc UI causes failure with S-RAMP repo browser - java.lang.IllegalArgumentException: No PolicyContextHandler for key=javax.servlet.http.HttpServletRequest
Undeploying DT gov and DT Goc UI causes failure with S-RAMP repo browser - ja...
Status: CLOSED DUPLICATE of bug 1016591
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: DT Governance, RT Governance (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Eric Wittmann
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 13:20 EDT by Len DiMaggio
Modified: 2015-08-02 19:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-22 08:16:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (208.98 KB, image/png)
2013-10-16 13:22 EDT, Len DiMaggio
no flags Details
Server log (103.77 KB, text/plain)
2013-10-16 13:22 EDT, Len DiMaggio
no flags Details

  None (edit)
Description Len DiMaggio 2013-10-16 13:20:42 EDT
Description of problem:

Is there some connection between the DT Gov and DT Gov UI .wars and user authentication with the S-RAMP browser? 

See steps below to recreate.

Version-Release number of selected component (if applicable):
ER4.respin3

How reproducible:
100%

Steps to Reproduce:

1. Install ER4, accept all defaults

2. Start the server

3. Verify that you can access the (empty) S-RAMP repo artifacts - http://localhost:8080/s-ramp-ui/#artifacts - without error

4) Undeploy DT Gov and DT Gov UI:
mv dtgov-ui.war.deployed dtgov.war.deployed /tmp

5) Refresh the browser at: http://localhost:8080/s-ramp-ui/#artifacts

Actual results:

These exceptions are displayed in the web UI:

Error Refreshing Ontology List
org.overlord.sramp.atom.err.SrampAtomException: Authentication failure while attempting to access the S-RAMP repository.

Error searching for artifacts.
org.overlord.sramp.atom.err.SrampAtomException:Authentication failure while attempting to access the S-RAMP repository.

See the attached server log, screen shot and log fragment below.

Expected results:
No exceptions.

Additional info:

This exception is written to the server log:

13:10:19,294 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-4) JBAS015877: Stopped deployment dtgov-ui.war (runtime-name: dtgov-ui.war) in 1181ms
13:10:20,161 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-2) JBAS015877: Stopped deployment dtgov.war (runtime-name: dtgov.war) in 2050ms
13:10:20,497 INFO  [org.jboss.as.server] (DeploymentScanner-threads - 1) JBAS018558: Undeployed "dtgov-ui.war" (runtime-name: "dtgov-ui.war")
13:10:20,498 INFO  [org.jboss.as.server] (DeploymentScanner-threads - 1) JBAS018558: Undeployed "dtgov.war" (runtime-name: "dtgov.war")
13:10:25,519 INFO  [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 2) JBAS015003: Found dtgov.war in deployment directory. To trigger deployment create a file called dtgov.war.dodeploy
13:10:25,520 INFO  [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 2) JBAS015003: Found dtgov-ui.war in deployment directory. To trigger deployment create a file called dtgov-ui.war.dodeploy
13:10:34,708 ERROR [stderr] (http-/127.0.0.1:8080-12) java.lang.IllegalArgumentException: No PolicyContextHandler for key=javax.servlet.http.HttpServletRequest
13:10:34,709 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at javax.security.jacc.PolicyContext.getContext(PolicyContext.java:96)
13:10:34,709 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at org.overlord.commons.auth.jboss7.SAMLBearerTokenLoginModule.login(SAMLBearerTokenLoginModule.java:112)
13:10:34,710 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
13:10:34,710 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
13:10:34,710 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
13:10:34,710 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at java.lang.reflect.Method.invoke(Method.java:606)
13:10:34,710 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at javax.security.auth.login.LoginContext.invoke(LoginContext.java:784)
13:10:34,710 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at javax.security.auth.login.LoginContext.access$000(LoginContext.java:203)
13:10:34,710 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at javax.security.auth.login.LoginContext$4.run(LoginContext.java:698)
13:10:34,711 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at javax.security.auth.login.LoginContext$4.run(LoginContext.java:696)
13:10:34,711 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at java.security.AccessController.doPrivileged(Native Method)
13:10:34,711 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at javax.security.auth.login.LoginContext.invokePriv(LoginContext.java:695)
13:10:34,711 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at javax.security.auth.login.LoginContext.login(LoginContext.java:594)
13:10:34,711 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at org.jboss.security.authentication.JBossCachedAuthenticationManager.defaultLogin(JBossCachedAuthenticationManager.java:408)
13:10:34,711 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at org.jboss.security.authentication.JBossCachedAuthenticationManager.proceedWithJaasLogin(JBossCachedAuthenticationManager.java:345)
13:10:34,712 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at org.jboss.security.authentication.JBossCachedAuthenticationManager.authenticate(JBossCachedAuthenticationManager.java:333)
13:10:34,712 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at org.jboss.security.authentication.JBossCachedAuthenticationManager.isValid(JBossCachedAuthenticationManager.java:146)
13:10:34,712 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at org.jboss.as.web.security.JBossWebRealm.authenticate(JBossWebRealm.java:216)
13:10:34,712 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at org.apache.catalina.authenticator.BasicAuthenticator.authenticate(BasicAuthenticator.java:178)
13:10:34,712 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:447)
13:10:34,712 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at org.jboss.as.web.security.SecurityContextAssociationValve.invoke(SecurityContextAssociationValve.java:169)
13:10:34,713 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:145)
13:10:34,713 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:97)
13:10:34,713 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:102)
13:10:34,713 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:336)
13:10:34,713 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856)
13:10:34,713 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:653)
13:10:34,714 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:920)
13:10:34,714 ERROR [stderr] (http-/127.0.0.1:8080-12) 	at java.lang.Thread.run(Thread.java:724)
13:10:34,789 ERROR [stderr] (http-/127.0.0.1:8080-13) java.lang.IllegalArgumentException: No PolicyContextHandler for key=javax.servlet.http.HttpServletRequest
13:10:34,789 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at javax.security.jacc.PolicyContext.getContext(PolicyContext.java:96)
13:10:34,790 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at org.overlord.commons.auth.jboss7.SAMLBearerTokenLoginModule.login(SAMLBearerTokenLoginModule.java:112)
13:10:34,790 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
13:10:34,790 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
13:10:34,790 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
13:10:34,790 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at java.lang.reflect.Method.invoke(Method.java:606)
13:10:34,791 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at javax.security.auth.login.LoginContext.invoke(LoginContext.java:784)
13:10:34,791 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at javax.security.auth.login.LoginContext.access$000(LoginContext.java:203)
13:10:34,791 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at javax.security.auth.login.LoginContext$4.run(LoginContext.java:698)
13:10:34,791 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at javax.security.auth.login.LoginContext$4.run(LoginContext.java:696)
13:10:34,792 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at java.security.AccessController.doPrivileged(Native Method)
13:10:34,792 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at javax.security.auth.login.LoginContext.invokePriv(LoginContext.java:695)
13:10:34,792 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at javax.security.auth.login.LoginContext.login(LoginContext.java:594)
13:10:34,792 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at org.jboss.security.authentication.JBossCachedAuthenticationManager.defaultLogin(JBossCachedAuthenticationManager.java:408)
13:10:34,792 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at org.jboss.security.authentication.JBossCachedAuthenticationManager.proceedWithJaasLogin(JBossCachedAuthenticationManager.java:345)
13:10:34,793 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at org.jboss.security.authentication.JBossCachedAuthenticationManager.authenticate(JBossCachedAuthenticationManager.java:333)
13:10:34,793 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at org.jboss.security.authentication.JBossCachedAuthenticationManager.isValid(JBossCachedAuthenticationManager.java:146)
13:10:34,793 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at org.jboss.as.web.security.JBossWebRealm.authenticate(JBossWebRealm.java:216)
13:10:34,793 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at org.apache.catalina.authenticator.BasicAuthenticator.authenticate(BasicAuthenticator.java:178)
13:10:34,794 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:447)
13:10:34,794 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at org.jboss.as.web.security.SecurityContextAssociationValve.invoke(SecurityContextAssociationValve.java:169)
13:10:34,794 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:145)
13:10:34,794 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:97)
13:10:34,794 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:102)
13:10:34,795 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:336)
13:10:34,795 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856)
13:10:34,795 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:653)
13:10:34,795 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:920)
13:10:34,796 ERROR [stderr] (http-/127.0.0.1:8080-13) 	at java.lang.Thread.run(Thread.java:724)
Comment 2 Len DiMaggio 2013-10-16 13:22:00 EDT
Created attachment 813072 [details]
Screenshot
Comment 3 Len DiMaggio 2013-10-16 13:22:25 EDT
Created attachment 813073 [details]
Server log
Comment 4 Gary Brown 2013-10-17 03:35:44 EDT
This issue maybe the same problem affecting rtgov: https://bugzilla.redhat.com/show_bug.cgi?id=1016591
Comment 5 Eric Wittmann 2013-10-22 08:16:55 EDT

*** This bug has been marked as a duplicate of bug 1016591 ***

Note You need to log in before you can comment on or make changes to this bug.