Bug 1019981 - OpenStack-4.0 rhel-x86_64-server-6-ost-4 channel maps are missing
Summary: OpenStack-4.0 rhel-x86_64-server-6-ost-4 channel maps are missing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager-migration-data
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Alex Wood
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel66
TreeView+ depends on / blocked
 
Reported: 2013-10-16 17:49 UTC by John Sefler
Modified: 2014-10-14 07:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no documentation required
Clone Of:
Environment:
Last Closed: 2014-10-14 07:45:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1384 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2014-10-14 01:27:50 UTC

Description John Sefler 2013-10-16 17:49:57 UTC
Description of problem:
product-certs.json has been updated with new OpenStack-4.0 channel mappings.
subscription-manager-migration-data needs to be regenerated to pull them in.


Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-2.0.4-1.el6.noarch


How reproducible:


Steps to Reproduce:
[root@jsefler-6 ~]# grep rhel-x86_64-server-6-ost-4 /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
[root@jsefler-6 ~]# 


Actual results:
no mappings

Expected results:
Mappings for these four channels...
[root@jsefler-6 cdn]# grep rhel-x86_64-server-6-ost-4 product-certs.json
    "rhel-x86_64-server-6-ost-4": {
    "rhel-x86_64-server-6-ost-4-cts": {
    "rhel-x86_64-server-6-ost-4-cts-debuginfo": {
    "rhel-x86_64-server-6-ost-4-debuginfo": {


Additional info:

Comment 2 John Sefler 2013-10-16 18:21:46 UTC
Channel mappings are also missing for the rhel-x86_64-server-6-ost-beta
Should these be included in subscription-manager-migration-data too?

[root@jsefler-6 cdn]# grep rhel-x86_64-server-6-ost-beta product-certs.json
    "rhel-x86_64-server-6-ost-beta": {
    "rhel-x86_64-server-6-ost-beta-cts": {
    "rhel-x86_64-server-6-ost-beta-cts-debuginfo": {
    "rhel-x86_64-server-6-ost-beta-debuginfo": {

Comment 3 RHEL Program Management 2013-10-19 18:44:25 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 4 John Sefler 2013-10-21 18:45:22 UTC
Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-2.0.5-1.el6.noarch

[root@jsefler-6 ~]# grep rhel-x86_64-server-6-ost-4 /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
rhel-x86_64-server-6-ost-4: OpenStack-4.0-x86_64-246d432e005c-191.pem
rhel-x86_64-server-6-ost-4-cts: OpenStack-4.0-CTS-x86_64-8fe420f53388-208.pem
rhel-x86_64-server-6-ost-4-cts-debuginfo: OpenStack-4.0-CTS-x86_64-8fe420f53388-208.pem
rhel-x86_64-server-6-ost-4-debuginfo: OpenStack-4.0-x86_64-246d432e005c-191.pem
[root@jsefler-6 ~]# 

VERIFIED: channels from comment 0 are now mapped to product certs


[root@jsefler-6 ~]# grep rhel-x86_64-server-6-ost-beta /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
rhel-x86_64-server-6-ost-beta: OpenStack-Beta-x86_64-2046a38a8a9f-220.pem
rhel-x86_64-server-6-ost-beta-cts: OpenStack-Beta-CTS-x86_64-d7a59cfd2249-221.pem
rhel-x86_64-server-6-ost-beta-cts-debuginfo: OpenStack-Beta-CTS-x86_64-d7a59cfd2249-221.pem
rhel-x86_64-server-6-ost-beta-debuginfo: OpenStack-Beta-x86_64-2046a38a8a9f-220.pem
[root@jsefler-6 ~]# 

VERIFIED: channels from comment 2 are now mapped to product certs

Comment 5 errata-xmlrpc 2014-10-14 07:45:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1384.html


Note You need to log in before you can comment on or make changes to this bug.