Bug 1020001 - Host group activation key list is not obvious
Host group activation key list is not obvious
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Activation Keys (Show other bugs)
Nightly
x86_64 Linux
unspecified Severity low (vote)
: Unspecified
: 6.0
Assigned To: Christine Fouant
Katello QA List
http://projects.theforeman.org/issues...
: Reopened, Triaged, UserExperience
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 14:38 EDT by Roy Williams
Modified: 2017-08-07 13:51 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Release Note
Doc Text:
Users need to select in this widget in order to activate it.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-07 13:51:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 7753 None None None 2016-04-26 13:04 EDT

  None (edit)
Description Roy Williams 2013-10-16 14:38:35 EDT
Description of problem:
Activation keys that have appeared previously in Foreman under the Host Groups configuration do not show existing keys now.

Version-Release number of selected component (if applicable):
1.5.1-1.git.6.65c0073.el6

How reproducible:
Easily

Steps to Reproduce:
1. Create Activation Key
2. Create a host group and go to activation keys section within forman. 
3. Look for Activation Key that was created

Actual results:
No keys appear here underneath the "Subscriptions information based on selected activation keys:" message, but can be populated manually...

Expected results:
It should display Activation Keys below "Subscriptions information based on selected activation keys:"

Additional info:
Comment 1 Justin Sherrill 2013-10-16 14:54:49 EDT
After discussions in IRC, this is actually working, it is just not obvious.  When you click 'reload data from katello', a spinner pops up and goes away, but nothing appears.   

The user has to click within the input box to see a dropdown of available keys.  We should make this more obvious.
Comment 2 Bryan Kearney 2014-01-21 14:08:02 EST
Moving to Sat6 to be tracked there. Upstream bugs are moving to redmine.
Comment 3 RHEL Product and Program Management 2014-01-21 14:18:53 EST
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 6 Dominic Cleal 2014-01-22 04:32:25 EST
Activation key code is in Katello, not Foreman.
Comment 8 Christine Fouant 2014-09-30 12:46:36 EDT
Created redmine issue http://projects.theforeman.org/issues/7753 from this bug
Comment 9 Bryan Kearney 2015-08-25 13:22:46 EDT
Upstream bug component is WebUI
Comment 10 Bryan Kearney 2015-08-25 13:56:00 EDT
Upstream bug component is Content Management
Comment 11 Bryan Kearney 2015-08-25 13:57:43 EDT
Upstream bug component is WebUI
Comment 12 Bryan Kearney 2015-08-25 16:02:22 EDT
Upstream bug component is WebUI
Comment 13 Bryan Kearney 2015-08-25 16:22:49 EDT
Upstream bug component is Activation Keys
Comment 17 Bryan Kearney 2017-02-07 13:23:35 EST
I do not see this bug being addressed in the near future. There is an upstream issue created, and we will ship it as soon as it is released. However, we will not be tracking this downstream.
Comment 18 Andrew Sanders 2017-06-29 11:15:36 EDT
(In reply to Bryan Kearney from comment #17)
> I do not see this bug being addressed in the near future. There is an
> upstream issue created, and we will ship it as soon as it is released.
> However, we will not be tracking this downstream.

Bryan,
  I have a support case open for a customer that I'm tracking against this feature.  Could we please keep this bugzilla open until the upstream patch is included and shipped in a future version of Satellite?
Comment 19 Andrew Sanders 2017-07-13 11:27:52 EDT
Bryan,
  Since there's an upstream issue to track this can we please keep this bugzilla open so that the upstream bug can be tracked and tied to an official satellite 6.x release?

Note You need to log in before you can comment on or make changes to this bug.