This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1020002 - packstack not setting glance qpid_hostname
packstack not setting glance qpid_hostname
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
4.0
Unspecified Unspecified
low Severity high
: rc
: 4.0
Assigned To: Martin Magr
Dafna Ron
storage
:
Depends On:
Blocks: 1040649
  Show dependency treegraph
 
Reported: 2013-10-16 14:42 EDT by Steve Reichard
Modified: 2013-12-19 19:28 EST (History)
11 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.19.dev935.el6ost
Doc Type: Release Note
Doc Text:
Cause: Consequence: Fix: Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:28:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
answer file (12.99 KB, text/plain)
2013-10-16 14:42 EDT, Steve Reichard
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 57428 None None None Never
OpenStack gerrit 61731 None None None Never

  None (edit)
Description Steve Reichard 2013-10-16 14:42:03 EDT
Description of problem:

Using the attached answer file with packstack which has qpid running on a separate host, the glance qpid_host is not being set correctly.

[root@spr4 ~]# source keystonerc_admin 
[root@spr4 ~(keystone_admin)]# grep qpid_host /etc/glance/*
/etc/glance/glance-api.conf:qpid_host = localhost
[root@spr4 ~(keystone_admin)]# 


Version-Release number of selected component (if applicable):


[root@spr4 ~(keystone_admin)]# yum list installed | grep -i -e openstack
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Django14.noarch            1.4.4-1.el6ost         @OpenStack-4.0-Puddle         
PyYAML.x86_64              3.10-3.1.el6           @OpenStack-4.0-Puddle         
crudini.noarch             0.3-2.el6ost           @OpenStack-4.0-Puddle         
dnsmasq.x86_64             2.48-13.el6            @OpenStack-4.0-Puddle         
dnsmasq-utils.x86_64       2.48-13.el6            @OpenStack-4.0-Puddle         
facter.x86_64              1.6.6-1.el6ost         @OpenStack-4.0-Puddle         
hiera.noarch               1.0.0-3.el6_4          @OpenStack-4.0-Puddle         
                                                  @OpenStack-4.0-Puddle         
libyaml.x86_64             0.1.3-1.1.el6          @OpenStack-4.0-Puddle         
novnc.noarch               0.4-8.el6ost           @OpenStack-4.0-Puddle         
openstack-dashboard.noarch 2013.2-0.15.rc2.el6ost @OpenStack-4.0-Puddle         
openstack-dashboard-theme.noarch
                           2013.2-0.15.rc2.el6ost @OpenStack-4.0-Puddle         
openstack-glance.noarch    2013.2-0.12.rc1.el6ost @OpenStack-4.0-Puddle         
openstack-keystone.noarch  2013.2-0.14.rc1.el6ost @OpenStack-4.0-Puddle         
openstack-neutron.noarch   2013.2-0.12.rc1.el6ost @OpenStack-4.0-Puddle         
openstack-neutron-openvswitch.noarch
                           2013.2-0.12.rc1.el6ost @OpenStack-4.0-Puddle         
openstack-nova-api.noarch  2013.2-0.25.rc1.el6ost @OpenStack-4.0-Puddle         
openstack-nova-cert.noarch 2013.2-0.25.rc1.el6ost @OpenStack-4.0-Puddle         
openstack-nova-common.noarch
                           2013.2-0.25.rc1.el6ost @OpenStack-4.0-Puddle         
openstack-nova-conductor.noarch
                           2013.2-0.25.rc1.el6ost @OpenStack-4.0-Puddle         
openstack-nova-console.noarch
                           2013.2-0.25.rc1.el6ost @OpenStack-4.0-Puddle         
openstack-nova-novncproxy.noarch
                           2013.2-0.25.rc1.el6ost @OpenStack-4.0-Puddle         
openstack-nova-scheduler.noarch
                           2013.2-0.25.rc1.el6ost @OpenStack-4.0-Puddle         
openstack-packstack.noarch 2013.2.1-0.6.dev763.el6ost
                                                  @OpenStack-4.0-Puddle         
openstack-selinux.noarch   0.1.2-11.el6ost        @OpenStack-4.0-Puddle         
openstack-utils.noarch     2013.2-1.el6ost        @OpenStack-4.0-Puddle         
openvswitch.x86_64         1.11.0-1.el6           @OpenStack-4.0-Puddle         
puppet.noarch              3.2.4-1.el6_4          @OpenStack-4.0-Puddle         
pyparsing.noarch           1.5.6-1.el6            @OpenStack-4.0-Puddle         
pysendfile.x86_64          2.0.0-3.el6            @OpenStack-4.0-Puddle         
python-alembic.noarch      0.4.2-1.el6ost         @OpenStack-4.0-Puddle         
python-anyjson.noarch      0.3.1-1.el6            @OpenStack-4.0-Puddle         
python-argparse.noarch     1.2.1-2.1.el6          @OpenStack-4.0-Puddle         
                           3.2-0.2.1.a3.el6       @OpenStack-4.0-Puddle         
python-boto.noarch         2.6.0-1.el6            @OpenStack-4.0-Puddle         
                           1.0.6-1.el6ost         @OpenStack-4.0-Puddle         
python-chardet.noarch      2.0.1-1.1.el6          @OpenStack-4.0-Puddle         
python-cinderclient.noarch 1.0.6-1.el6ost         @OpenStack-4.0-Puddle         
python-cliff.noarch        1.4.4-1.el6ost         @OpenStack-4.0-Puddle         
python-cmd2.noarch         0.6.4-6.el6ost         @OpenStack-4.0-Puddle         
python-d2to1.noarch        0.2.10-1.el6ost        @OpenStack-4.0-Puddle         
                           0.5-2.el6              @OpenStack-4.0-Puddle         
                           1.3-1.el6ost           @OpenStack-4.0-Puddle         
                           2013.2-0.15.rc2.el6ost @OpenStack-4.0-Puddle         
python-django-openstack-auth.noarch
                           1.1.2-1.el6ost         @OpenStack-4.0-Puddle         
                           0.5.0-1.el6ost         @OpenStack-4.0-Puddle         
python-dogpile-core.noarch 0.4.1-1.el6ost         @OpenStack-4.0-Puddle         
python-eventlet.noarch     0.9.17-2.el6           @OpenStack-4.0-Puddle         
python-glance.noarch       2013.2-0.12.rc1.el6ost @OpenStack-4.0-Puddle         
python-glanceclient.noarch 1:0.10.0-1.el6ost      @OpenStack-4.0-Puddle         
python-greenlet.x86_64     0.3.1-12.el6           @OpenStack-4.0-Puddle         
python-heatclient.noarch   0.2.4-1.el6ost         @OpenStack-4.0-Puddle         
python-httplib2.noarch     0.7.2-1.el6            @OpenStack-4.0-Puddle         
python-iso8601.noarch      0.1.4-2.el6            @OpenStack-4.0-Puddle         
python-jinja2-26.noarch    2.6-2.el6ost           @OpenStack-4.0-Puddle         
python-jsonpatch.noarch    1.2-2.el6ost           @OpenStack-4.0-Puddle         
python-jsonpointer.noarch  1.0-2.el6ost           @OpenStack-4.0-Puddle         
python-jsonschema.noarch   1.3.0-1.el6ost         @OpenStack-4.0-Puddle         
python-keyring.noarch      0.7-1.el6ost           @OpenStack-4.0-Puddle         
python-keystone.noarch     2013.2-0.14.rc1.el6ost @OpenStack-4.0-Puddle         
                           1:0.3.2-6.el6ost       @OpenStack-4.0-Puddle         
python-lockfile.noarch     0.8-5.el6              @OpenStack-4.0-Puddle         
python-mako.noarch         0.5.0-5.el6ost         @OpenStack-4.0-Puddle         
python-migrate.noarch      0.7.1-1.el6ost         @OpenStack-4.0-Puddle         
python-neutron.noarch      2013.2-0.12.rc1.el6ost @OpenStack-4.0-Puddle         
                           2.2.6-1.el6ost         @OpenStack-4.0-Puddle         
python-nova.noarch         2013.2-0.25.rc1.el6ost @OpenStack-4.0-Puddle         
python-novaclient.noarch   1:2.15.0-1.el6ost      @OpenStack-4.0-Puddle         
python-oauth2.noarch       1.5.211-5.el6ost       @OpenStack-4.0-Puddle         
python-ordereddict.noarch  1.1-2.1.el6            @OpenStack-4.0-Puddle         
python-oslo-config.noarch  1:1.2.1-1.el6ost       @OpenStack-4.0-Puddle         
python-passlib.noarch      1.5.3-1.el6            @OpenStack-4.0-Puddle         
                           1.5.0-5.el6            @OpenStack-4.0-Puddle         
python-pbr.noarch          0.5.21-2.el6ost        @OpenStack-4.0-Puddle         
python-prettytable.noarch  0.6.1-1.el6            @OpenStack-4.0-Puddle         
python-pyudev.noarch       0.15-1.el6             @OpenStack-4.0-Puddle         
python-requests.noarch     1.1.0-3.1.1.el6        @OpenStack-4.0-Puddle         
python-routes1.12.noarch   1.12.3-4.el6           @OpenStack-4.0-Puddle         
python-six.noarch          1.1.0-2.1.el6          @OpenStack-4.0-Puddle         
                           0.7.8-1.el6ost         @OpenStack-4.0-Puddle         
python-stevedore.noarch    0.11-1.el6ost          @OpenStack-4.0-Puddle         
python-swiftclient.noarch  1.6.0-1.el6ost         @OpenStack-4.0-Puddle         
python-urllib3.noarch      1.5-5.1.1.el6          @OpenStack-4.0-Puddle         
python-versiontools.noarch 1.9.1-3.el6            @OpenStack-4.0-Puddle         
python-warlock.noarch      1.0.1-1.el6ost         @OpenStack-4.0-Puddle         
python-webob1.0.noarch     1.0.8-3.el6            @OpenStack-4.0-Puddle         
python-webob1.2.noarch     1.2.3-2.2.el6ost       @OpenStack-4.0-Puddle         
python-websockify.noarch   0.5.1-1.el6ost         @OpenStack-4.0-Puddle         
pyxattr.x86_64             0.5.0-1.el6            @OpenStack-4.0-Puddle         
redhat-access-plugin-openstack.noarch
                           1.2.0-5.el6ost         @OpenStack-4.0-Puddle         
ruby-augeas.x86_64         0.4.1-1.el6ost         @OpenStack-4.0-Puddle         
ruby-shadow.x86_64         1.4.1-13.el6_4         @OpenStack-4.0-Puddle         
[root@spr4 ~(keystone_admin)]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.5 Beta (Santiago)
[root@spr4 ~(keystone_admin)]#  uname -r
2.6.32-419.el6.x86_64
[root@spr4 ~(keystone_admin)]# 




How reproducible:

Easy.
I've done it on several environments with various RHOS 4 puddles.




Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Steve Reichard 2013-10-16 14:42:40 EDT
Created attachment 813092 [details]
answer file
Comment 3 Alvaro Lopez Ortega 2013-11-15 07:41:33 EST
Flavio, Martin will reach out to you on this one.
Comment 6 Joe Gdaniec 2013-11-26 22:07:50 EST
Was just wrestling with this same issue this evening.

An additional consideration is that it appears the right configuration parameter to be setting in glance-api.conf is in fact qpid_hostname and not qpid_host.  

See:  https://bugs.launchpad.net/glance/+bug/1242715
Comment 9 Haim 2013-12-12 07:28:23 EST
moving back to assigned, bug was not resolved, qpid_host in glance.conf is still set to localhost and not to the qpid controller machine, hence, nothing works. 
had to change it manually and restart all services. 

openstack-ceilometer-common-2013.2-4.el6ost.noarch
openstack-selinux-0.1.3-2.el6ost.noarch
openstack-ceilometer-compute-2013.2-4.el6ost.noarch
openstack-glance-2013.2-4.el6ost.noarch
openstack-swift-plugin-swift3-1.0.0-0.20120711git.1.el6ost.noarch
openstack-swift-1.10.0-2.el6ost.noarch
openstack-utils-2013.2-2.el6ost.noarch
openstack-nova-common-2013.2-9.el6ost.noarch
openstack-neutron-2013.2-14.el6ost.noarch
openstack-neutron-openvswitch-2013.2-14.el6ost.noarch
openstack-nova-compute-2013.2-9.el6ost.noarch
openstack-cinder-2013.2-8.el6ost.noarch
openstack-swift-proxy-1.10.0-2.el6ost.noarch
Comment 10 Stephen Gordon 2013-12-12 08:59:02 EST
Two questions from my side here:

1) Does this impact both Foreman and Packstack installs?

2) Is this a regression or an issue that was present in the puppet modules for RHOS 3 as well?
Comment 11 Stephen Gordon 2013-12-12 09:27:56 EST
Resetting the release note field here as if we don't end up taking this fix we need to document it.
Comment 12 Martin Magr 2013-12-12 09:29:37 EST
This impacts packstack installations. This is present in puppet modules for RHOS 3 as well.
Comment 18 errata-xmlrpc 2013-12-19 19:28:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.