Bug 1020056 - failure to create live USB stick from DVD ISO, attempt to access beyond end of device
failure to create live USB stick from DVD ISO, attempt to access beyond end o...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 18:40 EDT by Chris Murphy
Modified: 2013-10-16 22:29 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-16 22:22:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
livecd-iso-to-disk full output (805.38 KB, text/plain)
2013-10-16 18:40 EDT, Chris Murphy
no flags Details
journal.log (4.24 MB, text/plain)
2013-10-16 18:43 EDT, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2013-10-16 18:40:46 EDT
Created attachment 813131 [details]
livecd-iso-to-disk full output

Description of problem: Failure to create a bootable USB stick from Fedora-20-Beta-TC4-x86_64-DVD.iso to a 16GB USB stick. The creating system is Fedora 20, up-to-date.

Version-Release number of selected component (if applicable):
livecd-tools-20.0-1.fc20.x86_64

How reproducible:
DVD ISO, always. Never with live or netinst ISOs.

Steps to Reproduce:
1. GPT partition a 16GB USB stick with one 16GB partition, type EF00, formatted 'mkfs.vfat -F32 -n EFI'; and then cat /usr/share/syslinux/mbr.bin > device

2. livecd-iso-to-disk --noverify --efi --overlay-size-mb 1000 /run/media/chris/FATFIRE/Fedora-20-Beta-TC4-x86_64-DVD.iso /dev/sdb1

This should be ~5.9GB required. 16GB is available.

After the failure, df -h reports:
/dev/sdb1        15G  4.8G   11G  33% /mnt

Actual results:

Numerous errors by livecd-iso-to-disk
rsync: read errors mapping "/media/srctmp.irOmwX/Packages/k/kde-settings-pulseaudio-20-3.fc20.1.noarch.rpm": Input/output error (5)

Numerous errors in dmesg

[30353.166991] attempt to access beyond end of device
[30353.166994] loop0: rw=0, want=9781556, limit=8388607

Expected results:
Not this.

Additional info:
Comment 1 Chris Murphy 2013-10-16 18:43:09 EDT
Created attachment 813132 [details]
journal.log
Comment 2 Chris Murphy 2013-10-16 18:44:23 EDT
Filesystem      Size  Used Avail Use% Mounted on
/dev/sdb1        15G  4.8G   11G  33% /mnt


So it's definitely not full.
Comment 3 Chris Murphy 2013-10-16 18:59:39 EDT
Removing the overlay option does not fix this.
Comment 4 Brian Lane 2013-10-16 19:36:35 EDT
Why the heck are you trying to manually setup the stick? Pass --format and --reset-mbr to litd.
Comment 5 Chris Murphy 2013-10-16 22:22:45 EDT
Because I enjoy doing things the hard way, but that isn't the cause of this bug. The cause is user error.

The original download ISO passes checksum. But it was copied to a 2nd hard drive, which was then used as the source for litd. And that 2nd hard drive partition is formatted FAT32. And the ISO is bigger than 4GB. So it's being truncated in exactly the same way each time.

This is because in 2013, f'n Apple still is in the pleistocene, with read only NTFS support, making FAT32 the go between rw volume format in common between linux and OS X. I'm not sure if I'm angrier with myself or Apple right now.
Comment 6 Chris Murphy 2013-10-16 22:29:16 EDT
FWIW with the good ISO, the original description steps produces a working USB stick.

But to make my dunce cap fully complete, seeing as I'm using a non-journaled fs in FAT32, I could use the non-journaled hfsplus support in linux which is of course rw for both OS's.

Note You need to log in before you can comment on or make changes to this bug.