Bug 1020068 - 100% CPU usage after suspend
100% CPU usage after suspend
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
19
i386 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 19:47 EDT by Simão Afonso
Modified: 2014-02-11 09:39 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-11 09:39:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Result fo journalctl around the bug (2.84 MB, text/plain)
2013-11-24 07:00 EST, Simão Afonso
no flags Details

  None (edit)
Description Simão Afonso 2013-10-16 19:47:38 EDT
Description of problem:
I have an Asus X201E with Fedora 19 and Cinnamon.
After suspending the computer, NetworkManager sucessfully reconnects to the network, but CPU usage keeps at 100% until I reboot, rendering the computer unusable.

Version-Release number of selected component (if applicable):
kernel 3.11.4-201.fc19
NetworkManager 1:0.9.8.2-9.git20130709.fc19

How reproducible:
always


Steps to Reproduce:
1.Suspend
2.Resume

Actual results:
The CPU usage shoots up to 100%

Expected results:
Back to idle

Additional info:
Comment 1 Jirka Klimes 2013-10-17 06:28:54 EDT
Is it really NetworkManager process that eats the CPU? You can run 'top' to see the processes.
If it is NetworkManager and the computer is responding (a bit at least), could you attach to the running NetworkManager to get backtrace?

$ sudo gdb -p <PID of NM>
...
then inside gdb
(gdb) t a a bt
Comment 2 Simão Afonso 2013-10-17 07:06:13 EDT
I assumed it was NetworkManager because it happened at the same time the network connections pops up. The process using the 100% CPU is actually
kworker/0:1
I tried to get a backtrace by that method and but it doesn't work
ptrace: Operation not permitted

I tried with an older kernel
kernel 3.9.5-301.fc19
and the problem goes away.
That was the only kernel I found with yum, how can I get a more recent one?
Comment 3 Simão Afonso 2013-10-17 12:27:16 EDT
I just tested my other PC with kernel 3.11.4-201.fc19 and it has no problem suspending. It has mostly the same software, but it's a Toshiba Qosmio F60.
Comment 4 Simão Afonso 2013-10-20 06:59:24 EDT
After some more testing I'm pretty sure NetworkManager is originating this problem. I had network connections in range, suspended the PC and when resumed NetworkManager still notified about disconnecting from the network.
Comment 5 Simão Afonso 2013-10-23 12:27:50 EDT
I can confirm the problem persists in the new kernel
3.11.6-200.fc19.i686
It's definitively on NetworkManager
Comment 6 Dan Williams 2013-11-13 15:19:49 EST
Can we get some journal logs showing NetworkManager output from a bit before this problem occurs?
Comment 7 Simão Afonso 2013-11-24 07:00:51 EST
Created attachment 828274 [details]
Result fo journalctl around the bug

Sorry for taking so long, only got around checking this.

I appended the result of
$ journalctl -f > journal.log

I started before I lowered the screen and kept for about a minute.
Comment 8 Simão Afonso 2013-12-04 10:54:23 EST
The latest NetworkManager version (0.9.8.8) fixed this for me. I can now suspend my PC. Thanks, whoever fixed it.
Comment 9 Jirka Klimes 2014-02-11 09:39:11 EST
(In reply to Simão Afonso from comment #8)
> The latest NetworkManager version (0.9.8.8) fixed this for me. I can now
> suspend my PC. Thanks, whoever fixed it.

Closing per the last comment. Feel free to re-open should the problem occur again.

Note You need to log in before you can comment on or make changes to this bug.