Bug 1020074 - [GSS](6.4.z) EJB clients do not attempt to reconnect to any receivers until all receivers have failed
[GSS](6.4.z) EJB clients do not attempt to reconnect to any receivers until a...
Status: CLOSED WONTFIX
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: EJB (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Radovan STANCEL
Jan Martiska
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 20:19 EDT by Kyle Lape
Modified: 2017-07-21 12:40 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
This release of JBoss EAP 6 carries an issue in the EJB component. EJB clients should attempt to reconnect to receivers when they detect a failed connection. Instead the connection attempt is not made until there are no available receivers. As a result, this makes it ineffective to use this method in a load balancing configuration. The cause of this problem is still under investigation.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-21 12:40:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker EJBCLIENT-94 Major Closed EJB clients do not attempt to reconnect to any receivers until all receivers have failed 2018-06-13 14:21 EDT
Red Hat Knowledge Base (Solution) 888213 None None None 2016-02-15 18:48 EST

  None (edit)
Description Kyle Lape 2013-10-16 20:19:14 EDT
Clients should attempt to reconnect as soon as it realizes a connection has gone down, but currently it doesn't try to reconnect until there are no more available receivers. This has the potential to make this method of load balancing unfair.
Comment 2 Dimitris Andreadis 2013-10-24 14:27:28 EDT
Assigning jpai@redhat.com EJB issues to david.lloyd@redhat.com. Please re-assign to Cheng or others as needed.
Comment 3 Jan Martiska 2014-07-02 09:24:04 EDT
Proposing for EAP 6.4.
Comment 4 Kabir Khan 2014-08-22 11:44:22 EDT
Setting to MODIFIED since should be solved by ejb-client 1.0.26 upgrade (https://bugzilla.redhat.com/show_bug.cgi?id=1104257)
Comment 10 Enrique Gonzalez Martinez 2015-05-25 03:50:51 EDT
commit was reverted. returning this to the pool.

Note You need to log in before you can comment on or make changes to this bug.