Bug 1020092 - [RFE] Long list boxes should have associated single line input.
Summary: [RFE] Long list boxes should have associated single line input.
Keywords:
Status: CLOSED DUPLICATE of bug 1234180
Alias: None
Product: Bugzilla
Classification: Community
Component: Query/Bug List
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: 4.4
Assignee: PnT DevOps Devs
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-10-17 02:05 UTC by Carlos O'Donell
Modified: 2018-12-09 06:29 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-23 07:45:40 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 950315 unspecified CLOSED Use AJAX for the component list when creating bugs 2020-10-14 00:28:05 UTC

Internal Links: 950315

Description Carlos O'Donell 2013-10-17 02:05:46 UTC
Description of problem:

I constantly work on RHEL issues and the component list box has hundreds of entries. Each and every time I need to scroll to the components of interest and that wastes time and makes me less productive.

In general any list box that grows beyond some configurable limit should automatically grow an edit box that allows you to type a comma separated list of entries which are equivalent to selecting the same entries from the list box.

This allows advanced users to simply tab and type into the various edit boxes without needing to pick from long list boxes.

Version-Release number of selected component (if applicable):
Current version.

How reproducible:
Configure bugzilla with 1000 components and notice how time consuming it is to pick components out of a 1000 entry list box.


Steps to Reproduce:
1. Go to search e.g. https://bugzilla.redhat.com/query.cgi
2. Select `glibc' from the Component: list box.
3. Continue with the rest of your search.

Actual results:
It takes the average human 20-30 seconds to scroll through the list and find the entry, that's too long.

Expected results:
Type in `glibc' into a single line edit box for component and continue with the rest of the search.

Additional info:
As a workaround narrowing the components down by selecting Classification and Product doesn't help because the list is still too long.

As a workaround selecting the list box and typing `g' doesn't help because the list of things that start with `g' is still too large.

Note: This feature is present in other bug trackers. At least in Roundup (python based tracker) there is the ability to either type in a comma separated list of items or pick the items manually with either the edit box or list box being updated after the search to contain the same information.

Business rationale:
This would make using bugzilla much much much faster and save time doing searches when picking components.

Comment 1 Jason McDonald 2013-11-18 01:08:25 UTC
Bug 950315 (released in Bugzilla 4.4.0009 on October 3rd, 2013) changed the component list to use a line edit and auto-filtered drop-down list for products with >200 components (currently RHEL and Fedora).  That change only applied to the enter_bug form and not to the search form, but perhaps some/most of that code could be reused for the search form.

Comment 2 Jeff Bastian 2013-11-18 15:04:49 UTC
(In reply to Carlos O'Donell from comment #0)
> As a workaround selecting the list box and typing `g' doesn't help because
> the list of things that start with `g' is still too large.


You can type more than the just the first character: type 'glibc' and it will go directly to glibc.    (You must type quickly, though.  If you pause a bit between 'g' and 'l', then it will jump to components that start with 'l' instead of 'gl'.)

That being said, I too would like a box to enter a comma-separated list of components because I often need to select more than one component.  If I want to search both 'kernel' and 'glibc' components, I can only type the name for one of the components and then I to scroll to find and CTRL-click the second component to search both.  (If you type the second component name, it will de-select the first.)

Comment 3 Jason McDonald 2014-05-09 00:39:08 UTC
I suspect this request should first be submitted to the upstream Bugzilla project (https://bugzilla.mozilla.org/enter_bug.cgi?product=Bugzilla) to see if they are willing to us the cost of carrying this as a Red Hat customization.

Comment 5 Jeff Fearn 🐞 2015-07-23 07:45:40 UTC
Closing this as it's basically covered by using the selectize widget.

*** This bug has been marked as a duplicate of bug 1234180 ***


Note You need to log in before you can comment on or make changes to this bug.