Bug 10201 - egcs-1.1.2-24 does not define __i586__ and __i686__ preprocessor flags.
Summary: egcs-1.1.2-24 does not define __i586__ and __i686__ preprocessor flags.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: egcs   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-16 08:46 UTC by nkbj
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-22 14:49:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description nkbj 2000-03-16 08:46:12 UTC
egcs-1.1.2-24 (Red Hat Linux 6.1) does not define the __i586__ or __i686__
preprocessor flags when the -march=i586 or -march=i686 command line
switches are used. They define the flags __pentium__/__pentiumpro__ in
stead. I think they should define both, as this can lead to miscompiled
kernels and other problems (see e.g. linux/include/linux/linkage.h).

Comment 1 Cristian Gafton 2000-05-22 14:49:59 UTC
assigned to jakub

Comment 2 Jakub Jelinek 2000-09-04 14:28:08 UTC
gcc 2.95 and 2.96 behaves the same way and I think it is right, just all
programs should use __pentium__/__pentiumpro__/__k6__/__athlon__ defines
and their __tune_ variants. linux/linkage.h has been changed since then
in 2.4, btw.


Note You need to log in before you can comment on or make changes to this bug.