Bug 102011 - yum crash when cleaning
yum crash when cleaning
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: distribution (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Mike McLean
:
Depends On: 103754
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-08 16:53 EDT by Chris Ricker
Modified: 2014-01-21 17:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-11 14:43:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2003-08-08 16:53:14 EDT
Filed against distro, since there is no yum component in bugzilla

I installed rawhide yum on a RHL 9 box, then used yum upgrade to upgrade that
system to severn beta1. Once upgraded to severn beta1, I used yum update to
upgrade to today's rawhide. Now, when I try to clean all the spooled files out
from /var/cache/yum, I get the following:

[cricker@yoshimi cricker]$ sudo yum clean
Gathering header information file(s) from server(s)
Server: Red Hat Linux 9.0.93 - i386 - Base
Finding updated packages
Cleaning packages and old headers
Traceback (most recent call last):
  File "/usr/bin/yum", line 45, in ?
    yummain.main(sys.argv[1:])
  File "yummain.py", line 240, in main
  File "clientStuff.py", line 843, in take_action
  File "clientStuff.py", line 596, in clean_up_old_headers
OSError: [Errno 2] No such file or directory:
'/var/cache/yum/base/headers/librsvg-devel-0-1.0.2-9.i386.hdr'
[cricker@yoshimi cricker]$ 

Okay, is the file really missing?

[cricker@yoshimi cricker]$ ls /var/cache/yum/base/headers/librsvg*
/var/cache/yum/base/headers/librsvg2-0-2.2.3-3.i386.hdr
/var/cache/yum/base/headers/librsvg2-devel-0-2.2.3-3.i386.hdr
[cricker@yoshimi cricker]$ 

looks like a header yum is still expecting to be there from severn beta1, but
which is gone b/c it was replaced by a newer header from rawhide

Downloading updated headers doesn't help:

[cricker@yoshimi cricker]$ sudo yum check-update
Gathering header information file(s) from server(s)
Server: Red Hat Linux 9.0.93 - i386 - Base
Finding updated packages
Downloading needed headers
[cricker@yoshimi cricker]$ sudo yum clean
Gathering header information file(s) from server(s)
Server: Red Hat Linux 9.0.93 - i386 - Base
Finding updated packages
Cleaning packages and old headers
Traceback (most recent call last):
  File "/usr/bin/yum", line 45, in ?
    yummain.main(sys.argv[1:])
  File "yummain.py", line 240, in main
  File "clientStuff.py", line 843, in take_action
  File "clientStuff.py", line 596, in clean_up_old_headers
OSError: [Errno 2] No such file or directory:
'/var/cache/yum/base/headers/rpmdb-redhat-0-9.0.93-0.20030718.i386.hdr'
[cricker@yoshimi cricker]$ 

Obviously, I can delete everything under /var/cache/yum to clean up, but it
looks like yum clean needs to be a little more robust here....
Comment 1 Seth Vidal 2003-08-09 10:51:30 EDT
yum bugs are better reported at:
https://devel.linux.duke.edu/bugzilla/

Could you try the latest daily of yum and see if this is still affecting you?
Comment 2 Seth Vidal 2003-08-09 21:14:57 EDT
https://devel.linux.duke.edu/bugzilla/show_bug.cgi?id=73

Same bug -  should have a catch for it for 2.0.1 - due out shortly.

it's an attempt to delete a file that isn't there, I just need to catch the
exception and move along. it doesn't really matter if the file isn't there on
the clean.
Comment 3 Seth Vidal 2003-08-09 21:22:21 EDT
one more note - I just realized what was going on and it's fairly stupid.

I test to see if the rpm for the header is in the rpmdb - if it is then I delete
the header.

then I test to see if the header is no longer in the header.info file, if it is
then I delete the header.

Both of those can be true so it throws the error.

Comment 4 Seth Vidal 2003-08-09 21:59:55 EDT
fixed in cvs - check that bug number from linux.duke.edu above. That has a patch.

Comment 5 Seth Vidal 2003-08-09 22:09:04 EDT
Resolving this as NEXTRELEASE - which means of yum not of rhl :)

y'all need a 'fixed'
:)
Comment 6 Chris Ricker 2003-09-04 12:35:23 EDT
I'm reopening this -- it's not fixed in RH, even if it is fixed upstream
Comment 7 Seth Vidal 2003-10-11 14:43:12 EDT
it's fixed in fedora core test 2.


Note You need to log in before you can comment on or make changes to this bug.