Bug 1020142 - modcluster subsystem XSDs do not describe worker-timeout attribute
modcluster subsystem XSDs do not describe worker-timeout attribute
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: mod_cluster (Show other bugs)
6.1.0
All All
low Severity low
: DR6
: EAP 6.3.0
Assigned To: Radoslav Husar
Michal Karm Babacek
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 02:51 EDT by Jay SenSharma
Modified: 2015-07-19 20:59 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In previous versions of JBoss EAP 6, the mod_cluster XSD used for validations did not specify worker-timeout attribute. This meant that using XSD to validate configuration might have failed validation even though the configuration was correct and correctly parsed by the server. The XSD schema has been fixed and now using XSD schema for validation when using worker-timeout attribute will now pass validation.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-28 11:43:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-2303 Major Resolved mod_cluster XSD is missing property and worker-timeout definitions 2016-08-04 02:19 EDT

  None (edit)
Description Jay SenSharma 2013-10-17 02:51:30 EDT
Description of problem:

Any of the XSD present inside the "jboss-eap-6.1/docs/schema/*.xsd" location does not include the information about the modcluster subsystem setting "worker-timeout" however it can be added in the modcluster subsystem.  Which looks like the XSDs are not describing about this attribute.


Version-Release number of selected component (if applicable):


How reproducible:
N/A

Steps to Reproduce: (N/A)
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Jay SenSharma 2013-10-17 03:19:47 EDT
Upstream Wildfly also has issue reported:
https://issues.jboss.org/browse/WFLY-2303
Comment 2 Michal Karm Babacek 2013-10-17 03:30:35 EDT
No Jay, mod_cluster as such has virtually nothing to do with Clustering component.
Comment 3 JBoss JIRA Server 2013-10-17 03:52:00 EDT
Radoslav Husar <rhusar@redhat.com> made a comment on jira WFLY-2303

https://github.com/wildfly/wildfly/pull/5272
Comment 4 Radoslav Husar 2013-10-17 03:58:11 EDT
Started the process for 6.3. -- there is no 6.3, so 6.2..

The upstream is already fixed, see WFLY-2303.

@Michal: the reporter just copied the component from upstream issue where we dont differetiate between modcluster and clustering. Nevertheless, its better to use the specific component in EAP issue tracker.
Comment 6 Michal Karm Babacek 2014-03-31 08:51:32 EDT
EAP 6.3.0.DR6 O.K.
Comment 7 Radoslav Husar 2014-06-30 07:50:16 EDT
Documentation: this is minor, but I have provided the text anyway.

Note You need to log in before you can comment on or make changes to this bug.