Bug 1020151 - [QE] (6.3.0) Add user utility should create properties file if it not exists
Summary: [QE] (6.3.0) Add user utility should create properties file if it not exists
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Scripts and Commands
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Darran Lofthouse
QA Contact: Petr Kremensky
Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks: 872441 1072367
TreeView+ depends on / blocked
 
Reported: 2013-10-17 07:21 UTC by Petr Kremensky
Modified: 2014-03-04 13:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1072367 (view as bug list)
Environment:
Last Closed: 2014-03-04 13:32:42 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Petr Kremensky 2013-10-17 07:21:37 UTC
Description of problem:
 Add-user utility gives us the ability to specify properties files which should be used to store users. However error is thrown once user tries to use properties file that doesn't exist. If this is a desired behaviour we may explicitly mention this in add-user script help message.

Version-Release number of selected component (if applicable):
 EAP 6.2.0.ER6

How reproducible:
 always

Steps to Reproduce:
 1. Navigate into $EAP_HOME/bin folder
 2. Run: jboss-eap-6.2/bin]$ ./add-user.sh -u appuser1 -p password1! -up appusers.properties

Actual results:
 * Error * 
JBAS015234: No appusers.properties files found.

Expected results:
 Properties file is created. 

Additional info:
 If there is a good reason for not creating the properties file we should at least mention this in script help message and documentation (BZ872441).
Example 4.4. Create a user belonging to single group using alternate properties files to store the information.
http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6.2/html-single/Administration_and_Configuration_Guide/index.html#Add-user_Script_Command_Line_Examples

Comment 1 sgilda 2013-10-17 12:26:55 UTC
Please let me know if the plans are to fix this. As Petr said, if there are no plans to create the file if it doesn't exist, I need to document it.

Comment 3 sgilda 2013-10-24 12:25:11 UTC
Does anyone have an update on this issue? I need to know ASAP if I need to document this in the Administration and Configuration Guide (https://bugzilla.redhat.com/show_bug.cgi?id=872441).

Comment 4 Darran Lofthouse 2013-10-24 12:49:55 UTC
No plans to look into this for EAP 6.2.

Better error messages may be appropriate in a future release but the intention of add-user is to be adding users to the property files already in use by the server i.e. we do expect them to exist.

Comment 5 Darran Lofthouse 2014-03-04 13:22:46 UTC
I am NACKing this on the basis that creation of property files is not an intended function of add-user

When the properties file name is specified add-user searches known locations for the file and outputs the error reported here if the file is not found in any of those locations.

At this point add-user does not know which of the locations it should even create the file in, the error message also potentially means there is an un-startable server as there is likely also a server referencing files that do not exist.

Comment 6 Petr Kremensky 2014-03-04 13:32:42 UTC
The behaviour of add user was documented as part of BZ872441 so I believe we can close this one.


Note You need to log in before you can comment on or make changes to this bug.