Bug 1020160 - Can't delete storage connection
Can't delete storage connection
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-api (Show other bugs)
3.3
x86_64 Linux
unspecified Severity unspecified
: ---
: 3.3.1
Assigned To: Daniel Erez
Aharon Canan
storage
:
Depends On:
Blocks: 1019391
  Show dependency treegraph
 
Reported: 2013-10-17 03:34 EDT by Sven Kieske
Modified: 2016-02-10 14:07 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-25 07:01:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of REST-Client-Output (69.85 KB, image/png)
2013-10-17 03:34 EDT, Sven Kieske
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17864 None None None Never

  None (edit)
Description Sven Kieske 2013-10-17 03:34:26 EDT
Created attachment 813213 [details]
Screenshot of REST-Client-Output

Description of problem:

If I try to delete a storage connection via API-Call (no matter if via rest-client, curl, or ovirt-shell) the delete method fails.


Version-Release number of selected component (if applicable):

this occurs in ovirt 3.3

How reproducible:

always

Steps to Reproduce:
1. find a storage connection id, e.g. brows to the specific api entrypoint:
https://www.example.com/api/storageconnections 
2. try do delete this connection via curl/rest-client/ovirt-shell:
e.g.:
[oVirt shell (connected)]# remove storageconnection 84970346-ae22-49cf-8a4c-c1bd27a0b7a4

Actual results:
in ovirt-shell you get:
error:
status: 404
reason: Not Found
detail: Entity not found: null

But you can list the connection via shell, so it exists:

[oVirt shell (connected)]# show storageconnection
84970346-ae22-49cf-8a4c-c1bd27a0b7a4

id     : 84970346-ae22-49cf-8a4c-c1bd27a0b7a4
address: server1
path   : /var/lib/exports/export
type   : nfs

Via REST-Client you get: "The specified HTTP method is not allowed for the requested resource" (See the attached screenshot)

Expected results:

The Storageconnection gets deleted

Additional info:

The Storage Domain associated to this connection was an export domain, which got deleted, but the connection persisted.

As an side effect, we can no longer add additional local storage domain, in a third local storage datacenter because then it says:
"can't add storage connection, connection already exists"
Comment 1 Itamar Heim 2013-10-17 03:39:49 EDT
i think this is only in 3.3.1, which is just about to beta
Comment 2 Sven Kieske 2013-10-17 05:34:29 EDT
So this feature doesn't exist in 3.3.0:

http://www.ovirt.org/Features/Manage_Storage_Connections#Detach_a_storage_connection_from_iscsi_storage_domain_.28DELETE.29 ?

Btw, the wiki seems to be down, I get:
"Can't contact the database server: Lost connection to MySQL server at 'reading initial communication packet', system error: 111 (127.7.52.129))"
Comment 3 Sven Kieske 2013-10-17 05:50:56 EDT
If this should get fixed in 3.3.1 I suggest to add this bug as a blocker
to the release tracking bug: https://bugzilla.redhat.com/show_bug.cgi?id=1019391
Comment 4 Sandro Bonazzola 2013-11-15 06:06:01 EST
Allon, Daniel, this is in modified state but there is no gerrit patch in external tracker
Comment 5 Sandro Bonazzola 2013-11-25 07:01:50 EST
oVirt 3.3.1 has been released

Note You need to log in before you can comment on or make changes to this bug.