Bug 1020177 - Failed to migrate gears with mysql cartridge
Failed to migrate gears with mysql cartridge
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: John Keck
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 04:10 EDT by Meng Bo
Modified: 2015-05-14 19:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 22:24:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2013-10-17 04:10:57 EDT
Description of problem:
Migrate gears with mysql cartridge will meet following error:

            "upgrade_script_mysql": {
                "context": {
                    "cartridge": "mysql", 
                    "rc": 1, 
                    "stderr": "/var/lib/openshift/525f49aba168100152000027/mysql/bin/upgrade: line 7: ${${new_cart_version#*.}%%.*}: bad substitution\n", 
                    "stdout": ""
                }, 
                "errors": [
                    "Upgrade script for mysql returned a non-zero exit code (1)"
                ], 
                "status": "incomplete"
            }


Version-Release number of selected component (if applicable):
devenv-stage_496 to devenv_3907

How reproducible:
always

Steps to Reproduce:
1. Create apps with mysql cartridge on devenv-stage_496
2. Upgrade the server and migrate the datastore 
3. Upgrade gears with oo-admin-upgrade
#oo-admin-upgrade upgrade-node --version 2.0.35 --ignore-cartridge-version


Actual results:
All the gears which contain mysql cartridge will fail due to the upgrade_script_mysql failed.

Expected results:
Mysql cartridge should be upgraded successfully.

Additional info:
Comment 2 Meng Bo 2013-10-21 04:16:10 EDT
Tested on devenv_3921, issue has been fixed.

Mysql cartridge for both scale app and non-scale can be upgraded without error.

Move bug to verified.

Note You need to log in before you can comment on or make changes to this bug.