Bug 1020179 - JMX operation to suppress state transfer failing on all platforms (OutdatedTopologyException)
JMX operation to suppress state transfer failing on all platforms (OutdatedTo...
Status: CLOSED DUPLICATE of bug 1188740
Product: JBoss Data Grid 6
Classification: JBoss
Component: Infinispan (Show other bugs)
6.4.0
Unspecified Unspecified
unspecified Severity medium
: DR2
: 6.5.0
Assigned To: Tristan Tarrant
Martin Gencur
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 04:20 EDT by Tomas Sykora
Modified: 2015-02-13 03:46 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-13 03:46:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
JmxSuppressSTserverErrorOutput.txt (52.71 KB, text/plain)
2013-10-17 04:20 EDT, Tomas Sykora
no flags Details
failedTestOutput (5.11 KB, text/plain)
2013-10-17 04:23 EDT, Tomas Sykora
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker ISPN-3720 Major Open JMX operation to suppress state transfer failing on all platforms (OutdatedTopologyException) 2015-10-18 07:30 EDT

  None (edit)
Description Tomas Sykora 2013-10-17 04:20:43 EDT
Created attachment 813232 [details]
JmxSuppressSTserverErrorOutput.txt

Failing on Windows 2008 R2 and Windows 2012, both Oracle JDK 6+7.

Please see attached files for standard server output which contains whole error stacktrace with org.infinispan.statetransfer.OutdatedTopologyException: Cache topology changed while the command was executing: expected 0, got 1 -- exception.

These tests are passing on RHELs and Solaris.
Comment 1 Tomas Sykora 2013-10-17 04:23:32 EDT
Created attachment 813234 [details]
failedTestOutput
Comment 3 Tomas Sykora 2014-10-08 11:29:50 EDT
We got this in 6.4
Comment 4 Tomas Sykora 2015-02-13 03:45:33 EST
https://github.com/infinispan/jdg/pull/497
Comment 5 Tomas Sykora 2015-02-13 03:46:12 EST

*** This bug has been marked as a duplicate of bug 1188740 ***

Note You need to log in before you can comment on or make changes to this bug.