Bug 1020185 - Failed to show Chinese characters in server monitor (Java Melody) diagrams.
Failed to show Chinese characters in server monitor (Java Melody) diagrams.
Status: CLOSED NOTABUG
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Damian Jansen
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 04:43 EDT by Ding-Yi Chen
Modified: 2014-04-15 22:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-15 22:32:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2013-10-17 04:43:25 EDT
Description of problem:
When viewing the server monitor page with Chinese browser (Browser locale is set to Chinese). The Chinese characters in Java melody diagrams are shown as boxes.

Chinese in tooltips are shown properly though.

This suggest that server cannot found any Chinese fonts.


Version-Release number of selected component (if applicable):
Zanata version 3.1.1-SNAPSHOT (20131017-1642)

How reproducible:
Always, if no Chinese fonts are installed in server.

Steps to Reproduce:
1. Make sure no Chinese fonts are installed in Zanata server.
2. Browser locale set to Chinese 
3. Sign in with admin role
4. Go to Administration menu -> Server Monitoring

Actual results:
Chinese characters are shown as boxes, as demonstrated in  

https://code.google.com/p/javamelody/issues/detail?id=150

Expected results:
Chinese charters are shown properly.

Additional info:
The "most proper" way to address this bug is include the font installation section in installation or administration guide.

Alternatively, force the English display.
Comment 1 Ding-Yi Chen 2014-04-15 22:32:49 EDT
This is neither a Zanata nor Java Melody bug, but a documentation bug.

Fixed content is at:

https://github.com/zanata/zanata-server/wiki/Installation-Guide#14-install-fonts

I hereby close it as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.