Bug 1020188 - force_clean_build marker does not work with jenkins builds
force_clean_build marker does not work with jenkins builds
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Andy Goldstein
libra bugs
:
Depends On:
Blocks: 1005123
  Show dependency treegraph
 
Reported: 2013-10-17 04:45 EDT by Zhe Wang
Modified: 2015-05-14 19:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 22:24:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhe Wang 2013-10-17 04:45:09 EDT
Description of problem:
Given an app with a Jenkins client added, the force_clean_build marker does not with its Jenkins builds. On the other hand, when removing the Jenkins client, force clean build works again.

This problem happens to Ruby cartridges only before Sprint 35 (https://bugzilla.redhat.com/show_bug.cgi?id=1005123), and now all web carts are affected.

Version-Release number of selected component (if applicable):
devenv_3907

How reproducible:
always

Steps to Reproduce:
1. create an app with Jenkins client added
2. install some dependencies to the app
3. check the Jenkins build log
4. create a force_clean_build and trigger another Jenkins build
5. check the log of the build in Step 4, to confirm if the dependencies in Step 2 are reinstalled
6. remove the Jenkins client and trigger a third Jenkins build

Actual results:
Take a JBossAS application as an example, in Step 3, we can see that the app was downloading and installing packages in its build. Moreover, in Step 5, the app was not reinstalling the packages in Step 2 even with the presence of a force_clean_build marker. The force_clean_build marker, however, works again after removing the Jenkins client from the app.


Expected results:
force_clean_build should work with Jenkins builds

Additional info:
Comment 1 Paul Morie 2013-10-17 17:37:52 EDT
*** Bug 1005123 has been marked as a duplicate of this bug. ***
Comment 3 openshift-github-bot 2013-10-18 18:30:15 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/f4b2367708d8f40046a11a49fc2f0d37fd3bd90c
Sync deployment metadata from jenkins builder

Write deployment metadata during build

Sync metadata from jenkins builder gear back upstream

Create new deployment directory for each jenkins build

Bug 1020188
Comment 4 openshift-github-bot 2013-10-20 13:28:15 EDT
Commit pushed to master at https://github.com/openshift/li

https://github.com/openshift/li/commit/f7de7cb508e426206414715185f6c1313ecbe2e8
Bug 1020188

Update jenkins_shell_command to create a new deployment directory for
each build and to record deployment metadata (git info, force clean
build, hot deploy) that will be synced back to the upstream gear.
Comment 5 Zhe Wang 2013-10-20 23:38:25 EDT
Verified in devenv_3921.

After creating a force_clean_build marker, the dependencies are installed again:

Fetching gem metadata from http://rubygems.org/..........

Installing rack (1.5.2) 
Installing ref (1.0.5) 
Using bundler (1.1.4) 
Your bundle is complete! It was installed into ./vendor/bundle

Note You need to log in before you can comment on or make changes to this bug.