Bug 1020189 - [RHSC] Commit button not enabled in the remove-bricks status dialog, even after the data migration has completed.
[RHSC] Commit button not enabled in the remove-bricks status dialog, even aft...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: RHGS 2.1.2
Assigned To: anmol babu
Shruti Sampat
: ZStream
Depends On: 1020331
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 04:53 EDT by Shruti Sampat
Modified: 2015-05-13 12:27 EDT (History)
7 users (show)

See Also:
Fixed In Version: cb7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:53:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (190.68 KB, image/png)
2013-10-17 04:53 EDT, Shruti Sampat
no flags Details
remove-brick-status (125.49 KB, image/png)
2013-10-22 10:14 EDT, anmol babu
no flags Details

  None (edit)
Description Shruti Sampat 2013-10-17 04:53:45 EDT
Created attachment 813242 [details]
screenshot

Description of problem:
------------------------
After the data migration for a remove brick operation completes, the Commit button in the remove-brick status dialog does not get enabled. The Commit menu item in the drop-down menu beside the remove brick icon is however enabled once data migration completes.

Version-Release number of selected component (if applicable):
Red Hat Storage Console Version: 2.1.2-0.0.scratch.beta1.el6_4 

How reproducible:
Always

Steps to Reproduce:
1. Create a volume and start it, mount it and create data on the mount point.
2. Start remove brick operation on the volume from the UI.
3. Once data migration is completed, check the status of remove brick from the UI.

Actual results:
Commit button is disabled.

Expected results:
Commit button should be enabled.

Additional info:
Find screenshot attached.
Comment 2 Dusmant 2013-10-21 02:54:51 EDT
Lets fix this bug in the next build : CB5
Comment 3 anmol babu 2013-10-22 10:14:51 EDT
Created attachment 815016 [details]
remove-brick-status
Comment 4 anmol babu 2013-10-22 10:19:57 EDT
Seems like the bug,is due to some error from the gluster side.Because,when I tried to reproduce it,when the remove-brick was completed,I could see the commit button in the pop up enabled as can be seen in my attachment.Also to add to this,the  remove brick status in the given attachment doesn't show the "completed" label indicating the possibility that status summary returned from the gluster may not be "FINISHED"(Button is enabled ONLY if status summary is "FINISHED").And also,this could be possible because,we can see the status for 3 other rows as unknown.So,this suggests that the bug may be in the aggregation of those results by gluster.
Comment 5 Shruti Sampat 2013-11-13 02:50:52 EST
Verified as fixed in Red Hat Storage Console Version: 2.1.2-0.23.master.el6_5. Commit button in the status dialog now enabled after data migration gets completed.
Comment 7 errata-xmlrpc 2014-02-25 02:53:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.