Bug 1020190 - RHS-C: Hide NFS setup, Application mode and Datacenter storage type from CONFIGURATION PREVIEW during rhsc-setup
RHS-C: Hide NFS setup, Application mode and Datacenter storage type from CONF...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: RHGS 2.1.2
Assigned To: Darshan
Prasanth
integration
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 04:55 EDT by Prasanth
Modified: 2015-05-13 12:28 EDT (History)
9 users (show)

See Also:
Fixed In Version: CB8
Doc Type: Bug Fix
Doc Text:
Previously, the NFS Setup and Datacenter Storage Type fields, which are not relevant to Red Hat Storage Console were displayed under configuration preview during setup. Now, with this update, only fields relevant to Red Hat Storage Console are displayed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:53:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20955 None None None Never

  None (edit)
Description Prasanth 2013-10-17 04:55:48 EDT
Description of problem:

NFS setup, Application mode and Datacenter storage type is seen in  CONFIGURATION PREVIEW during rhsc-setup. See below:


-------------------------------
          --== SYSTEM CONFIGURATION ==--
         
[ INFO  ] NFS configuration skipped with application mode Gluster
         
          --== END OF CONFIGURATION ==--
         
[ INFO  ] Stage: Setup validation
[WARNING] Less than 16384MB of memory is available
         
          --== CONFIGURATION PREVIEW ==--
         
          Database name                      : engine
          Database secured connection        : False
          Database host                      : localhost
          Database user name                 : engine
          Database host name validation      : False
          Datbase port                       : 5432
          NFS setup                          : False
          PKI organization                   : RedHat
          Application mode                   : gluster
          Firewall manager                   : iptables
          Host FQDN                          : vm07.lab.eng.blr.redhat.com
          Datacenter storage type            : nfs
          Configure local database           : True
          Set application as default page    : True
          Configure Apache SSL               : True
         
          Please confirm installation settings (OK, Cancel) [OK]: 
[ INFO  ] Stage: Transaction setup
[ INFO  ] Stopping engine service
[ INFO  ] Stage: Misc configuration
[ INFO  ] Stage: Package installation
[ INFO  ] Stage: Misc configuration
[ INFO  ] Initializing PostgreSQL
[ INFO  ] Creating PostgreSQL database
[ INFO  ] Configurating PostgreSQL
[ INFO  ] Creating database schema
[ INFO  ] Creating CA
[ INFO  ] Generating post install configuration file '/etc/ovirt-engine-setup.conf.d/20-setup-ovirt-post.conf'
[ INFO  ] Stage: Transaction commit
[ INFO  ] Stage: Closing up
         
          --== SUMMARY ==--
-------------------------------
Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. Install cb4 build as per 
http://rhsm.pad.engineering.redhat.com/rhsc-build-cb4
2. Run rhsc-setup and see the "CONFIGURATION PREVIEW"


Actual results: NFS setup, Application mode and Datacenter storage type are shown in the CONFIGURATION PREVIEW


Expected results: Since these are anyway not relevant to RHS-C, can we hide this??


Additional info:
Comment 2 Darshan 2013-11-18 03:54:12 EST
NFS setup and Datacenter storage type have been removed from configuration preview however Application mode does not seem irrelevant so it is retained.
Comment 3 Prasanth 2013-11-18 05:48:19 EST
Verified in cb8.

NFS setup and Datacenter storage type has been removed.

----------------------
          --== CONFIGURATION PREVIEW ==--
         
          Database name                      : engine
          Database secured connection        : False
          Database host                      : localhost
          Database user name                 : engine
          Database host name validation      : False
          Datbase port                       : 5432
          PKI organization                   : RedHat
          Application mode                   : gluster
          Firewall manager                   : iptables
          Host FQDN                          : rhs-client3.lab.eng.blr.redhat.com
          Configure local database           : True
          Set application as default page    : True
          Configure Apache SSL               : True
----------------------
Comment 4 Shalaka 2014-01-06 05:50:21 EST
Please review the edited DocText and confirm.
Comment 6 errata-xmlrpc 2014-02-25 02:53:48 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.