Bug 10202 - ifcfg problems with multiple pcmcia network drivers
ifcfg problems with multiple pcmcia network drivers
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-16 05:05 EST by lee.essen
Modified: 2007-04-18 12:26 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-14 14:40:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lee.essen 2000-03-16 05:05:40 EST
I have recently installed the linux-wlan drivers for a wireless network
card (which I know isn't part of RH, but the problems could occur with
several other types of card).

If I choose to use my ethernet pcmcia card (only) it gets assigned to eth0
and then the relevant eth0 configuration happens .... fine.

If I then plug in my WLAN card, it becomes eth1 ... etc, etc...

However, if I plug them in the other way around then the interface details
are swapped and the configurations are incorrect.

I have temporarily (and rather hackily) put a workaround in the
pcmcia/network script to work out the DRIVER and copy the correct ifcfg
file into place for the relevant card. This works ok but is a bit nasty!
(Perhaps a mac address based solution might be better)

Also, I notice that there is support for altering DNS entries if you use a
PPP link but not for any other kind of interface ... it might be an
improvement to support DNS modifications (otionally) with any type of
interface.

Thanks,

Lee.
Comment 1 David Hinds 2000-11-21 21:26:00 EST
This is a basic limitation of the Red Hat network configurator; it assumes that
the card that is eth0 is always the same card, which makes more sense for a
desktop with a static hardware configuration, but doesn't work if you have
multiple hot plugged interfaces.

The easiest workaround is to use the /etc/pcmcia/network and network.opts
scripts from the regular PCMCIA package instead of Red Hat's network script. 
Then you can specify your settings based on MAC address in the network.opts
file.

As a long term fix for Red Hat, I suggest that they not replace the PCMCIA
network script at all.  They can specify that "ifup" and "ifdown" be used by
default in the network.opts file instead.  Then, people who need the extra
capabilities have the tools they need, but people who don't will never know that
they are there.

- Dave
Comment 2 Bill Nottingham 2001-01-29 19:54:44 EST
assigning to kernel-pcmcia-cs
Comment 3 Stephen John Smoogen 2003-01-25 00:26:20 EST
Is this bug still relevant in 8.0 release and newer network configuration tools?
Comment 4 Jay Turner 2003-04-14 14:40:43 EDT
Closing out due to bit-rot.

Note You need to log in before you can comment on or make changes to this bug.