Bug 1020200 - Met "undefined local variable or method `uuid_and_namespace'" when upgrading scaled up gear for a scalable app
Met "undefined local variable or method `uuid_and_namespace'" when upgrading ...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Paul Morie
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 05:25 EDT by Meng Bo
Modified: 2015-05-14 19:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 22:24:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scaled_up_gear.log (8.05 KB, text/plain)
2013-10-17 05:25 EDT, Meng Bo
no flags Details

  None (edit)
Description Meng Bo 2013-10-17 05:25:07 EDT
Created attachment 813249 [details]
scaled_up_gear.log

Description of problem:
Create scalable app with at least two web gears, will met the following error during upgrade that gear:

"message": "undefined local variable or method `uuid_and_namespace' for #<OpenShift::GearUpgradeExtension:0x00000003274388>"

Version-Release number of selected component (if applicable):
devenv-stage_496 to devenv_3901

How reproducible:
always

Steps to Reproduce:
1. Create scalable app with multiple web gears on devenv-stage_496
2. Upgrade the server and migrate the datastore 
3. Upgrade gears with oo-admin-upgrade
#oo-admin-upgrade upgrade-node --version 2.0.35 --ignore-cartridge-version

Actual results:
Upgrade of the scaled up gears will fail due to error:
"undefined local variable or method `uuid_and_namespace' for #<OpenShift::GearUpgradeExtension:0x00000003274388>"


Expected results:
Should upgrade the gears successfully.

Additional info:
Full log attached
Comment 1 openshift-github-bot 2013-10-17 17:35:12 EDT
Commits pushed to master at https://github.com/openshift/li

https://github.com/openshift/li/commit/87abb75d413f567bc53f8554183e201ef606c931
Fix bug 1020200: upgrade gear registry for scaled-up apps

https://github.com/openshift/li/commit/d979377ca1b99454f4bce18471df0eba452eb2e3
Merge pull request #2009 from pmorie/bugs/1020200

Fix bug 1020200: upgrade gear registry for scaled-up apps
Comment 2 Jianwei Hou 2013-10-18 03:55:09 EDT
Verified this on devenv_3912, the error is gone when a scalable app is being migrated.

Note You need to log in before you can comment on or make changes to this bug.