Bug 1020201 - Quota isn't enforced in run VM
Quota isn't enforced in run VM
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Gilad Chaplik
Artyom
sla
:
Depends On:
Blocks: 3.3snap2
  Show dependency treegraph
 
Reported: 2013-10-17 05:29 EDT by Gilad Chaplik
Modified: 2016-02-10 15:14 EST (History)
7 users (show)

See Also:
Fixed In Version: is23
Doc Type: Bug Fix
Doc Text:
When creating a VM/Disk, and assigning a quota to that entity, the user performing the action ought to be a consumer of that quota (or sys/DC-admin). When a user runs a VM he will consume from the quota assigned to the entity, even if he isn't a consumer of that quota.
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19994 None None None Never
oVirt gerrit 20448 None None None Never
oVirt gerrit 20574 None None None Never

  None (edit)
Description Gilad Chaplik 2013-10-17 05:29:04 EDT
reported in oVirt's users list: http://www.mail-archive.com/users@ovirt.org/msg10659.html

Description of problem:
A user who isn't the quota consumer of a certain quota is able to run a VM which is attach to that quota.

How reproducible:
100%

Wasn't so reproducible since vm's quota drop down was populated by quotas which the user is a consumer of, but in create VM from template, the UI sets the quota with the template quota regardless of permissions.


Steps to Reproduce:
1. create Quota A (and assign it to User A), B (for admin).
2. admin creates a Template and assign it to quota B.
3. User A create a VM from Template and can select quota B.
4. User A runs VM.

Actual results:
The VM runs.

Expected results:
The VM should fail, because the User isn't a quota consumer of the VM's quota
Comment 1 Artyom 2013-11-18 10:03:34 EST
Verified on is23
Comment 2 Itamar Heim 2014-01-21 17:31:51 EST
Closing - RHEV 3.3 Released
Comment 3 Itamar Heim 2014-01-21 17:31:53 EST
Closing - RHEV 3.3 Released
Comment 4 Itamar Heim 2014-01-21 17:34:29 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.