Bug 1020276 - freemind-1.0.1 is available
freemind-1.0.1 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: freemind (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Simacek
Fedora Extras Quality Assurance
: FutureFeature, Triaged
: 1060550 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 07:17 EDT by Upstream Release Monitoring
Modified: 2014-06-02 09:26 EDT (History)
9 users (show)

See Also:
Fixed In Version: freemind-1.0.1-1.fc20
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-24 19:25:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2013-10-17 07:17:11 EDT
Latest upstream release: 1.0.0
Current version/release in Fedora Rawhide: 0.9.0-13.fc19
URL: http://sourceforge.net/api/file/index/project-name/freemind/mtime/desc/limit/100/rss

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Stanislav Ochotnicky 2014-02-03 04:12:58 EST
*** Bug 1060550 has been marked as a duplicate of this bug. ***
Comment 2 birger 2014-03-26 06:56:46 EDT
This is a real problem, as windows-users with 1.0.0 upgrade our shared mindmaps and my old 0.9.0 cannot open them anymore.
Comment 3 Upstream Release Monitoring 2014-04-14 03:26:46 EDT
Latest upstream release: 1.0.1
Current version/release in Fedora Rawhide: 0.9.0-13.fc19
URL: http://sourceforge.net/api/file/index/project-name/freemind/mtime/desc/limit/200/rss

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 4 Fedora Admin XMLRPC Client 2014-04-24 08:54:14 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Fedora Update System 2014-05-15 11:26:00 EDT
freemind-1.0.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/freemind-1.0.1-1.fc20
Comment 6 Fedora Update System 2014-05-15 11:36:06 EDT
freemind-1.0.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/freemind-1.0.1-1.fc19
Comment 7 Ali Akcaagac 2014-05-16 04:59:23 EDT
Cool thanks. I hope it doesn't have that much dependencies as 0.9.x had.
Comment 8 Ali Akcaagac 2014-05-16 05:02:44 EDT
Um ?

Total size: 91 M
Total download size: 75 M
Installed size: 196 M
Is this ok [y/d/N]: 

This is definately NOT ok. 200mb for a 9mb tool ?
Comment 9 Michael Simacek 2014-05-16 05:04:52 EDT
It has and there is nothing I can do about it as a maintainer of freemind. Almost all the unwanted dependencies are not pulled in as direct dependencies of freemind, but as dependencies of groovy, which is needed for the scripting plugin and is also shipped in upstream binary releases. I will reply to your bug with more details soon
Comment 10 Stanislav Ochotnicky 2014-05-16 05:19:34 EDT
(In reply to Michael Simacek from comment #9)
> It has and there is nothing I can do about it as a maintainer of freemind.
> Almost all the unwanted dependencies are not pulled in as direct
> dependencies of freemind, but as dependencies of groovy, which is needed for
> the scripting plugin and is also shipped in upstream binary releases. I will
> reply to your bug with more details soon

I'd suggest splitting at least some plugins into subpackages.
Comment 11 Fedora Update System 2014-05-16 06:08:06 EDT
Package freemind-1.0.1-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing freemind-1.0.1-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-6415/freemind-1.0.1-1.fc20
then log in and leave karma (feedback).
Comment 12 Michael Simacek 2014-05-16 07:12:49 EDT
Upstream freemind binary without plugins is 28.7MB. With plugins it has 37.6MB. I can split it, but freemind with plugins would still be the same size as it is now instead of 37MB, because groovy pulls in ant, junit, hamcrest, ivy, easymock, jansi, felix-osgi, eclipse-equinox, java-devel, tomcat-servlet, tomcat-jsp and many more unneeded and unrelated packages.
Comment 13 José Matos 2014-05-16 10:41:58 EDT
I have placed this in bodhi but I think that here it is a best place:

I have updated and I got an error loading a map created with 0.9.1:

Error while parsing file:freemind.main.XMLParseException: XML Parse Exception during parsing of a map element at line 1: Expected: =

Searching in the internet I got references to this error saying that 1.0rc3 had a fix for this problem.

In my case the fix was easy. Changing the header version to say version 1.0.1 instead of 0.9.1 was enough to get the document correctly loaded.

Other than it works.
Comment 14 Fedora Update System 2014-05-24 19:25:56 EDT
freemind-1.0.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2014-05-24 19:31:12 EDT
freemind-1.0.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Christian von Behren 2014-05-27 08:51:38 EDT
(In reply to José Matos from comment #13)
> In my case the fix was easy. Changing the header version to say version
> 1.0.1 instead of 0.9.1 was enough to get the document correctly loaded.
> 
> Other than it works.

Thanks so much - you saved my day ;-)
Comment 17 Chris Palmer 2014-05-28 07:36:17 EDT
Applying this update for fc19 (and I think also fc20) breaks freemind. I think the cause is a case mismatch: /bin/freemind puts "JMapViewer" (mixed case) into BASE_JARS, but the jmapviewer1.03-1.fc19 package installs "/usr/share/java/jmapviewer.jar" (lower case), so the jar file is never found.
Comment 18 Michael Simacek 2014-05-28 09:36:45 EDT
Verified, thanks for reporting it. This should not affect f20, only f19. I packaged JMapViewer using mvn_artifact, which was not available in f19, so I had to rewrite the spec to use add_maven_depmap and accidentaly mixed the case. I will try to correct it on either JMapViewer's or freemind's side.

I will also try to look into the header mismatch problem and submit a new update soon.
Comment 19 Michael Simacek 2014-06-01 06:34:34 EDT
The conversion error seems to be caused by bug in JDK's default XSLT transformer. I workaround this by forcing freemind to use Xalan transformer, which works fine for me.

I've submitted a new update for this issue (and the f19 name mismatch problem).
https://admin.fedoraproject.org/updates/freemind-1.0.1-2.fc20
https://admin.fedoraproject.org/updates/freemind-1.0.1-2.fc19

Please test whether it solves the problem.
Comment 20 Christian von Behren 2014-06-02 04:10:02 EDT
I can confirm, that the update fixes the header mismatch problem!
Comment 21 José Matos 2014-06-02 09:26:19 EDT
(In reply to Christian von Behren from comment #20)
> I can confirm, that the update fixes the header mismatch problem!

Me too.
I will add karma to this update... done. :-)

Note You need to log in before you can comment on or make changes to this bug.