Bug 1020282 - [RHSC] Error message on failure to start remove-brick is incorrect
[RHSC] Error message on failure to start remove-brick is incorrect
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: RHGS 2.1.2
Assigned To: Darshan
Shruti Sampat
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 07:35 EDT by Shruti Sampat
Modified: 2015-05-13 12:26 EDT (History)
6 users (show)

See Also:
Fixed In Version: cb11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:54:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21200 None None None Never

  None (edit)
Description Shruti Sampat 2013-10-17 07:35:02 EDT
Description of problem:
-----------------------
Error message displayed on the Console, on failure to start remove-brick operation is as follows - 

Error while executing action: Cannot start removing Gluster Volume. A task is in progress on the volume dis_vol in cluster test.

The part "Cannot start removing Gluster Volume" needs to be changed to "Cannot start removing brick(s)", as it is the brick that is being removed and not the volume.

Version-Release number of selected component (if applicable):
Red Hat Storage Console Version: 2.1.2-0.0.scratch.beta1.el6_4 

How reproducible:
Always

Steps to Reproduce:
1. Start remove brick on a volume and commit it.
2. Now try to start remove brick again, it fails because of BZ #1020205

Actual results:
The error message seen is incorrect as explained above.

Expected results:
Error message needs to be corrected as explained.

Additional info:
Comment 2 Shruti Sampat 2013-12-18 11:04:58 EST
Could not follow the "Steps to Reproduce" mentioned initially as BZ #1020205 is fixed. So simulated failure to start removing bricks by killing brick processes.

The error message now seen is like this - 

Error while executing action: Cannot start remove Gluster Brick(s). One or more bricks are down.

Marking as verified.
Comment 3 Darshan 2014-01-03 03:53:53 EST
doc_text not need as it is an intermediate build issue.
Comment 5 errata-xmlrpc 2014-02-25 02:54:15 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.