This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1020283 - [Forge] Got java runtime exception "unknow request parameter type integer" when run rhc setup in forge shell
[Forge] Got java runtime exception "unknow request parameter type integer" wh...
Status: CLOSED WONTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
: UpcomingRelease
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 07:36 EDT by XiuJuan Wang
Modified: 2015-06-11 17:36 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-06-11 17:36:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker FORGEPLUGINS-148 Blocker Closed Got java runtime exception "unknow request parameter type integer" when run rhc setup in forge shell 2015-06-11 22:17:31 EDT

  None (edit)
Description XiuJuan Wang 2013-10-17 07:36:06 EDT
Description of problem:
when rhc setup in forge shell, it got java runtime error message "unknow request parameter type integer".

Version-Release number of selected component (if applicable):
java version "1.8.0"
openshift 1.0.6.final
forge 1.4.1.final

How reproducible:
always

Steps to Reproduce:
1.create a new project in forge shell
2.run `rhc setup` in forge shell
3.

Actual results:
[forge-openshift--wxj-demo] forge-openshift--wxj-demo $ rhc setup 
 ? Enter the application name [forgeopenshiftw]  [forgeopenshiftw] testjbt]
***INFO*** Using RHLOGIN:xiuwang+5@redhat.com for https://ec2-174-129-78-163.compute-1.amazonaws.com
 ? Enter your Red Hat Openshift password: *
java.lang.RuntimeException: com.openshift.client.OpenShiftRequestException: Unknow request parameter type integer
	at com.redhat.openshift.forge.OpenShiftFacet.install(OpenShiftFacet.java:86)
	at org.jboss.forge.project.BaseProject.performInstallation(BaseProject.java:240)
	at org.jboss.forge.project.BaseProject.installFacet(BaseProject.java:166)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:491)
	at org.jboss.weld.bean.proxy.AbstractBeanInstance.invoke(AbstractBeanInstance.java:48)
	at org.jboss.weld.bean.proxy.ProxyMethodHandler.invoke(ProxyMethodHandler.java:125)
at org.jboss.weld.proxies.Project$-1946286523$Proxy$_$$_WeldClientProxy.installFacet(Project$-1946286523$Proxy$_$$_WeldClientProxy.java)
	at org.jboss.forge.shell.project.FacetInstallationHandler.performInstallation(FacetInstallationHandler.java:105)
	at org.jboss.forge.shell.project.FacetInstallationHandler.install(FacetInstallationHandler.java:81)
	at org.jboss.forge.shell.project.FacetInstallationHandler.installRequest(FacetInstallationHandler.java:59)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:491)
	at org.jboss.weld.util.reflection.SecureReflections$13.work(SecureReflections.java:305)
	at org.jboss.weld.util.reflection.SecureReflectionAccess.run(SecureReflectionAccess.java:54)
	at org.jboss.weld.util.reflection.SecureReflectionAccess.runAsInvocation(SecureReflectionAccess.java:163)
	at org.jboss.weld.util.reflection.SecureReflections.invoke(SecureReflections.java:299)
	at org.jboss.weld.introspector.jlr.WeldMethodImpl.invokeOnInstance(WeldMethodImpl.java:188)
	at org.jboss.weld.introspector.ForwardingWeldMethod.invokeOnInstance(ForwardingWeldMethod.java:59)
	at org.jboss.weld.injection.MethodInjectionPoint.invokeOnInstanceWithSpecialValue(MethodInjectionPoint.java:198)
	at org.jboss.weld.event.ObserverMethodImpl.sendEvent(ObserverMethodImpl.java:282)
	at org.jboss.weld.event.ObserverMethodImpl.sendEvent(ObserverMethodImpl.java:265)
	at org.jboss.weld.event.ObserverMethodImpl.notify(ObserverMethodImpl.java:234)
	at org.jboss.weld.manager.BeanManagerImpl.notifyObservers(BeanManagerImpl.java:635)
	at org.jboss.weld.manager.BeanManagerImpl.fireEvent(BeanManagerImpl.java:628)
	at org.jboss.weld.event.EventImpl.fire(EventImpl.java:75)
	at com.redhat.openshift.forge.OpenShiftPlugin.setup(OpenShiftPlugin.java:100)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:491)
	at org.jboss.forge.shell.command.Execution.perform(Execution.java:160)
	at org.jboss.forge.shell.command.fshparser.FSHRuntime.run(FSHRuntime.java:109)
	at org.jboss.forge.shell.command.fshparser.FSHRuntime.run(FSHRuntime.java:47)
	at org.jboss.forge.shell.ShellImpl$ExecutorThread.run(ShellImpl.java:796)
	at org.jboss.forge.shell.ShellImpl.execute(ShellImpl.java:819)
	at org.jboss.forge.shell.ShellImpl.doShell(ShellImpl.java:609)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:491)
	at org.jboss.weld.bean.proxy.AbstractBeanInstance.invoke(AbstractBeanInstance.java:48)
	at org.jboss.weld.bean.proxy.ProxyMethodHandler.invoke(ProxyMethodHandler.java:125)
	at org.jboss.forge.shell.ShellImpl$Proxy$_$$_WeldClientProxy.doShell(ShellImpl$Proxy$_$$_WeldClientProxy.java)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:491)
	at org.jboss.weld.util.reflection.SecureReflections$13.work(SecureReflections.java:305)
	at org.jboss.weld.util.reflection.SecureReflectionAccess.run(SecureReflectionAccess.java:54)
	at org.jboss.weld.util.reflection.SecureReflectionAccess.runAsInvocation(SecureReflectionAccess.java:163)
	at org.jboss.weld.util.reflection.SecureReflections.invoke(SecureReflections.java:299)
	at org.jboss.weld.introspector.jlr.WeldMethodImpl.invokeOnInstance(WeldMethodImpl.java:188)
	at org.jboss.weld.introspector.ForwardingWeldMethod.invokeOnInstance(ForwardingWeldMethod.java:59)
	at org.jboss.weld.injection.MethodInjectionPoint.invokeOnInstanceWithSpecialValue(MethodInjectionPoint.java:198)
	at org.jboss.weld.event.ObserverMethodImpl.sendEvent(ObserverMethodImpl.java:282)
	at org.jboss.weld.event.ObserverMethodImpl.sendEvent(ObserverMethodImpl.java:265)
	at org.jboss.weld.event.ObserverMethodImpl.notify(ObserverMethodImpl.java:234)
	at org.jboss.weld.manager.BeanManagerImpl.notifyObservers(BeanManagerImpl.java:635)
	at org.jboss.weld.manager.BeanManagerImpl.fireEvent(BeanManagerImpl.java:622)
	at org.jboss.weld.manager.BeanManagerImpl.fireEvent(BeanManagerImpl.java:616)
	at org.jboss.forge.shell.Bootstrap$1.run(Bootstrap.java:186)
	at java.lang.Thread.run(Thread.java:724)
Caused by: com.openshift.client.OpenShiftRequestException: Unknow request parameter type integer
	at com.openshift.internal.client.response.LinkParameterType.valueOfIgnoreCase(LinkParameterType.java:30)
	at com.openshift.internal.client.response.LinkParameter.<init>(LinkParameter.java:32)
	at com.openshift.internal.client.response.ResourceDTOFactory.createLinkParameter(ResourceDTOFactory.java:566)
	at com.openshift.internal.client.response.ResourceDTOFactory.createLinkParameters(ResourceDTOFactory.java:547)
	at com.openshift.internal.client.response.ResourceDTOFactory.createLinks(ResourceDTOFactory.java:276)
	at com.openshift.internal.client.response.ResourceDTOFactory.createApplication(ResourceDTOFactory.java:383)
	at com.openshift.internal.client.response.ResourceDTOFactory.createApplications(ResourceDTOFactory.java:353)
	at com.openshift.internal.client.response.ResourceDTOFactory.get(ResourceDTOFactory.java:113)
	at com.openshift.internal.client.RestService.request(RestService.java:92)
	at com.openshift.internal.client.RestService.request(RestService.java:76)
	at com.openshift.internal.client.AbstractOpenShiftResource$ServiceRequest.execute(AbstractOpenShiftResource.java:137)
	at com.openshift.internal.client.DomainResource.loadApplications(DomainResource.java:200)
	at com.openshift.internal.client.DomainResource.getOrLoadApplications(DomainResource.java:186)
	at com.openshift.internal.client.DomainResource.getApplications(DomainResource.java:192)
	at com.openshift.internal.client.DomainResource.getApplicationByName(DomainResource.java:145)
	at com.openshift.internal.client.DomainResource.hasApplicationByName(DomainResource.java:140)
	at com.redhat.openshift.forge.OpenShiftFacet.internalInstall(OpenShiftFacet.java:116)
	at com.redhat.openshift.forge.OpenShiftFacet.install(OpenShiftFacet.java:81)
	... 66 more
[forge-openshift--wxj-demo] forge-openshift--wxj-demo $ 

Expected results:
It should success and no error messages output

Additional info:
Comment 1 Andre Dietisheim 2013-10-24 07:50:48 EDT
This is very likely caused by the problem we found and fixed for the JBoss Tools for OpenShift in https://issues.jboss.org/browse/JBIDE-15399.
To know if this is matching, please verify that the client used is pre-2.4.0.Final. The solution is to simply upgrade the client lib that's used to 2.4.0.Final
Comment 2 Andre Dietisheim 2013-10-24 08:59:05 EDT
This is imho related to https://bugzilla.redhat.com/show_bug.cgi?id=1003037 which was fixed by removing env variable support from protocol 1.0. Is this a regression?
Comment 3 weiwei jiang 2013-10-28 01:28:27 EDT
I tried on forge 1.4.2.final, and do the following things, and now I have no idea how to upgrade to pre-2.4.0.Final.

[no project] forge-distribution-1.4.2.Final $ forge find-plugin openshift
Connecting to remote repository [https://raw.github.com/forge/plugin-repository/
master/repository.yaml]... connected!
 - openshift (com.redhat.openshift:forge-openshift-plugin:::)
        Author: Pete Muir <pmuir@redhat.com>
        Website: http://openshift.com
        Location: https://github.com/forge/plugin-openshift.git
        Tags: cloud, openshift, redhat, jboss, deploy, rhc
        Description: Plugins for creating cloud instances, managing existing clo
uds, and deploying applications to the Red Hat express cloud.

And the following is https://raw.github.com/forge/plugin-openshift/master/pom.xml
<?xml version="1.0" encoding="UTF-8"?>
<project
    xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"
    xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <modelVersion>4.0.0</modelVersion>
    <groupId>com.redhat.openshift</groupId>
    <artifactId>forge-openshift-plugin</artifactId>
    <version>1.0.6.Final</version>
    <properties>
        <forge.api.version>1.0.6.Final</forge.api.version>
        <jgit.version>2.0.0.201206130900-r</jgit.version>
        <log4j.extras.version>1.1</log4j.extras.version>
        <openshift.client.version>2.0.1</openshift.client.version>
        <jsch.version>0.1.48</jsch.version>
    </properties>
    ...
    <build>
        <finalName>forge-openshift-plugin</finalName>
        <plugins>
            <plugin>
                <artifactId>maven-compiler-plugin</artifactId>
                <version>2.3.2</version>
                <configuration>
                    <source>1.6</source>
                    <target>1.6</target>
                </configuration>
            </plugin>
        </plugins>
    </build>
Comment 4 Andre Dietisheim 2013-10-28 07:49:48 EDT
I am not the maintainer of this plugin thus I dont know either how one would upgrade this plugin to a latter openshift-java-client. I see 2 options here:

1) this issue is a regression (see comment above, see https://bugzilla.redhat.com/show_bug.cgi?id=1003037) and will go away when OpenShift is ifxed.

2) you pass this over to the maintainer of the forge plugin to let him upgrade the openshift-java-client.
Comment 5 XiuJuan Wang 2013-11-07 02:43:24 EST
Version-Release number of selected component (if applicable):
java version "1.7.0"
openshift 1.0.6.final

forge 1.4.2.final

Now, when create apps, forge has the same error 

[forge-openshift-demo] openshift $ rhc  setup 
***INFO*** Loaded OpenShift configuration from /home/openshift/.openshift/express.conf
 ? Enter the application name [forgeopenshiftd]  [forgeopenshiftd] ruby
***INFO*** Using RHLOGIN:xiuwang+3@redhat.com for https://stg.openshift.redhat.com
 ? Enter your Red Hat Openshift password: ******
java.lang.RuntimeException: com.openshift.client.OpenShiftRequestException: Unknow request parameter type integer
	at com.redhat.openshift.forge.OpenShiftFacet.install(OpenShiftFacet.java:86)
	at org.jboss.forge.project.BaseProject.performInstallation(BaseProject.java:240)
	at org.jboss.forge.project.BaseProject.installFacet(BaseProject.java:166)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.jboss.weld.bean.proxy.AbstractBeanInstance.invoke(AbstractBeanInstance.java:48)
	at org.jboss.weld.bean.proxy.ProxyMethodHandler.invoke(ProxyMethodHandler.java:125)
	at org.jboss.weld.proxies.Project$-1946286523$Proxy$_$$_WeldClientProxy.installFacet(Project$-1946286523$Proxy$_$$_WeldClientProxy.java)
	at org.jboss.forge.shell.project.FacetInstallationHandler.performInstallation(FacetInstallationHandler.java:105)
	at org.jboss.forge.shell.project.FacetInstallationHandler.install(FacetInstallationHandler.java:81)
	at org.jboss.forge.shell.project.FacetInstallationHandler.installRequest(FacetInstallationHandler.java:59)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.jboss.weld.util.reflection.SecureReflections$13.work(SecureReflections.java:305)
	at org.jboss.weld.util.reflection.SecureReflectionAccess.run(SecureReflectionAccess.java:54)
	at org.jboss.weld.util.reflection.SecureReflectionAccess.runAsInvocation(SecureReflectionAccess.java:163)
	at org.jboss.weld.util.reflection.SecureReflections.invoke(SecureReflections.java:299)
	at org.jboss.weld.introspector.jlr.WeldMethodImpl.invokeOnInstance(WeldMethodImpl.java:188)
	at org.jboss.weld.introspector.ForwardingWeldMethod.invokeOnInstance(ForwardingWeldMethod.java:59)
	at org.jboss.weld.injection.MethodInjectionPoint.invokeOnInstanceWithSpecialValue(MethodInjectionPoint.java:198)
	at org.jboss.weld.event.ObserverMethodImpl.sendEvent(ObserverMethodImpl.java:282)
	at org.jboss.weld.event.ObserverMethodImpl.sendEvent(ObserverMethodImpl.java:265)
	at org.jboss.weld.event.ObserverMethodImpl.notify(ObserverMethodImpl.java:234)
	at org.jboss.weld.manager.BeanManagerImpl.notifyObservers(BeanManagerImpl.java:635)
	at org.jboss.weld.manager.BeanManagerImpl.fireEvent(BeanManagerImpl.java:628)
	at org.jboss.weld.event.EventImpl.fire(EventImpl.java:75)
	at com.redhat.openshift.forge.OpenShiftPlugin.setup(OpenShiftPlugin.java:100)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.jboss.forge.shell.command.Execution.perform(Execution.java:160)
	at org.jboss.forge.shell.command.fshparser.FSHRuntime.run(FSHRuntime.java:109)
	at org.jboss.forge.shell.command.fshparser.FSHRuntime.run(FSHRuntime.java:47)
	at org.jboss.forge.shell.ShellImpl$ExecutorThread.run(ShellImpl.java:796)
	at org.jboss.forge.shell.ShellImpl.execute(ShellImpl.java:819)
	at org.jboss.forge.shell.ShellImpl.doShell(ShellImpl.java:609)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.jboss.weld.bean.proxy.AbstractBeanInstance.invoke(AbstractBeanInstance.java:48)
	at org.jboss.weld.bean.proxy.ProxyMethodHandler.invoke(ProxyMethodHandler.java:125)
	at org.jboss.forge.shell.ShellImpl$Proxy$_$$_WeldClientProxy.doShell(ShellImpl$Proxy$_$$_WeldClientProxy.java)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.jboss.weld.util.reflection.SecureReflections$13.work(SecureReflections.java:305)
	at org.jboss.weld.util.reflection.SecureReflectionAccess.run(SecureReflectionAccess.java:54)
	at org.jboss.weld.util.reflection.SecureReflectionAccess.runAsInvocation(SecureReflectionAccess.java:163)
	at org.jboss.weld.util.reflection.SecureReflections.invoke(SecureReflections.java:299)
	at org.jboss.weld.introspector.jlr.WeldMethodImpl.invokeOnInstance(WeldMethodImpl.java:188)
	at org.jboss.weld.introspector.ForwardingWeldMethod.invokeOnInstance(ForwardingWeldMethod.java:59)
	at org.jboss.weld.injection.MethodInjectionPoint.invokeOnInstanceWithSpecialValue(MethodInjectionPoint.java:198)
	at org.jboss.weld.event.ObserverMethodImpl.sendEvent(ObserverMethodImpl.java:282)
	at org.jboss.weld.event.ObserverMethodImpl.sendEvent(ObserverMethodImpl.java:265)
	at org.jboss.weld.event.ObserverMethodImpl.notify(ObserverMethodImpl.java:234)
	at org.jboss.weld.manager.BeanManagerImpl.notifyObservers(BeanManagerImpl.java:635)
	at org.jboss.weld.manager.BeanManagerImpl.fireEvent(BeanManagerImpl.java:622)
	at org.jboss.weld.manager.BeanManagerImpl.fireEvent(BeanManagerImpl.java:616)
	at org.jboss.forge.shell.Bootstrap$1.run(Bootstrap.java:186)
	at java.lang.Thread.run(Thread.java:744)
Caused by: com.openshift.client.OpenShiftRequestException: Unknow request parameter type integer
	at com.openshift.internal.client.response.LinkParameterType.valueOfIgnoreCase(LinkParameterType.java:30)
	at com.openshift.internal.client.response.LinkParameter.<init>(LinkParameter.java:32)
	at com.openshift.internal.client.response.ResourceDTOFactory.createLinkParameter(ResourceDTOFactory.java:566)
	at com.openshift.internal.client.response.ResourceDTOFactory.createLinkParameters(ResourceDTOFactory.java:547)
	at com.openshift.internal.client.response.ResourceDTOFactory.createLinks(ResourceDTOFactory.java:276)
	at com.openshift.internal.client.response.ResourceDTOFactory.createApplication(ResourceDTOFactory.java:383)
	at com.openshift.internal.client.response.ResourceDTOFactory.createApplications(ResourceDTOFactory.java:353)
	at com.openshift.internal.client.response.ResourceDTOFactory.get(ResourceDTOFactory.java:113)
	at com.openshift.internal.client.RestService.request(RestService.java:92)
	at com.openshift.internal.client.RestService.request(RestService.java:76)
	at com.openshift.internal.client.AbstractOpenShiftResource$ServiceRequest.execute(AbstractOpenShiftResource.java:137)
	at com.openshift.internal.client.DomainResource.loadApplications(DomainResource.java:200)
	at com.openshift.internal.client.DomainResource.getOrLoadApplications(DomainResource.java:186)
	at com.openshift.internal.client.DomainResource.getApplications(DomainResource.java:192)
	at com.openshift.internal.client.DomainResource.getApplicationByName(DomainResource.java:145)
	at com.openshift.internal.client.DomainResource.hasApplicationByName(DomainResource.java:140)
	at com.redhat.openshift.forge.OpenShiftFacet.internalInstall(OpenShiftFacet.java:116)
	at com.redhat.openshift.forge.OpenShiftFacet.install(OpenShiftFacet.java:81)
	... 66 more
Comment 6 weiwei jiang 2013-11-07 03:11:17 EST
Open an issue on https://issues.jboss.org/browse/FORGEPLUGINS-148 to track this issue
Comment 7 XiuJuan Wang 2013-11-28 01:10:36 EST
devenv_4081
java version "1.7.0_45"
openshift 1.0.6.final
forge 1.4.3.final

It is seem error changed.

[forge-openshift-demo] forge-openshift-demo $ rhc  setup --app jas7
***INFO*** Using RHLOGIN:xiuwang@redhat.com for https://ec2-184-73-36-143.compute-1.amazonaws.com
 ? Enter your Red Hat Openshift password: **
java.lang.RuntimeException: com.openshift.client.OpenShiftEndpointException: Could not request /api: javax.net.ssl.SSLProtocolException: handshake alert:  unrecognized_name
	at com.redhat.openshift.forge.OpenShiftFacet.install(OpenShiftFacet.java:86)
	at org.jboss.forge.project.BaseProject.performInstallation(BaseProject.java:240)
	at org.jboss.forge.project.BaseProject.installFacet(BaseProject.java:166)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.jboss.weld.bean.proxy.AbstractBeanInstance.invoke(AbstractBeanInstance.java:48)
	at org.jboss.weld.bean.proxy.ProxyMethodHandler.invoke(ProxyMethodHandler.java:125)
	at org.jboss.weld.proxies.Project$-1946286523$Proxy$_$$_WeldClientProxy.installFacet(Project$-1946286523$Proxy$_$$_WeldClientProxy.java)
	at org.jboss.forge.shell.project.FacetInstallationHandler.performInstallation(FacetInstallationHandler.java:105)
	at org.jboss.forge.shell.project.FacetInstallationHandler.install(FacetInstallationHandler.java:81)
	at org.jboss.forge.shell.project.FacetInstallationHandler.installRequest(FacetInstallationHandler.java:59)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.jboss.weld.util.reflection.SecureReflections$13.work(SecureReflections.java:305)
	at org.jboss.weld.util.reflection.SecureReflectionAccess.run(SecureReflectionAccess.java:54)
	at org.jboss.weld.util.reflection.SecureReflectionAccess.runAsInvocation(SecureReflectionAccess.java:163)
	at org.jboss.weld.util.reflection.SecureReflections.invoke(SecureReflections.java:299)
	at org.jboss.weld.introspector.jlr.WeldMethodImpl.invokeOnInstance(WeldMethodImpl.java:188)
	at org.jboss.weld.introspector.ForwardingWeldMethod.invokeOnInstance(ForwardingWeldMethod.java:59)
	at org.jboss.weld.injection.MethodInjectionPoint.invokeOnInstanceWithSpecialValue(MethodInjectionPoint.java:198)
	at org.jboss.weld.event.ObserverMethodImpl.sendEvent(ObserverMethodImpl.java:282)
	at org.jboss.weld.event.ObserverMethodImpl.sendEvent(ObserverMethodImpl.java:265)
	at org.jboss.weld.event.ObserverMethodImpl.notify(ObserverMethodImpl.java:234)
	at org.jboss.weld.manager.BeanManagerImpl.notifyObservers(BeanManagerImpl.java:635)
	at org.jboss.weld.manager.BeanManagerImpl.fireEvent(BeanManagerImpl.java:628)
	at org.jboss.weld.event.EventImpl.fire(EventImpl.java:75)
	at com.redhat.openshift.forge.OpenShiftPlugin.setup(OpenShiftPlugin.java:100)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.jboss.forge.shell.command.Execution.perform(Execution.java:160)
	at org.jboss.forge.shell.command.fshparser.FSHRuntime.run(FSHRuntime.java:109)
	at org.jboss.forge.shell.command.fshparser.FSHRuntime.run(FSHRuntime.java:47)
	at org.jboss.forge.shell.ShellImpl$ExecutorThread.run(ShellImpl.java:796)
	at org.jboss.forge.shell.ShellImpl.execute(ShellImpl.java:819)
	at org.jboss.forge.shell.ShellImpl.doShell(ShellImpl.java:609)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.jboss.weld.bean.proxy.AbstractBeanInstance.invoke(AbstractBeanInstance.java:48)
	at org.jboss.weld.bean.proxy.ProxyMethodHandler.invoke(ProxyMethodHandler.java:125)
	at org.jboss.forge.shell.ShellImpl$Proxy$_$$_WeldClientProxy.doShell(ShellImpl$Proxy$_$$_WeldClientProxy.java)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.jboss.weld.util.reflection.SecureReflections$13.work(SecureReflections.java:305)
	at org.jboss.weld.util.reflection.SecureReflectionAccess.run(SecureReflectionAccess.java:54)
	at org.jboss.weld.util.reflection.SecureReflectionAccess.runAsInvocation(SecureReflectionAccess.java:163)
	at org.jboss.weld.util.reflection.SecureReflections.invoke(SecureReflections.java:299)
	at org.jboss.weld.introspector.jlr.WeldMethodImpl.invokeOnInstance(WeldMethodImpl.java:188)
	at org.jboss.weld.introspector.ForwardingWeldMethod.invokeOnInstance(ForwardingWeldMethod.java:59)
	at org.jboss.weld.injection.MethodInjectionPoint.invokeOnInstanceWithSpecialValue(MethodInjectionPoint.java:198)
	at org.jboss.weld.event.ObserverMethodImpl.sendEvent(ObserverMethodImpl.java:282)
	at org.jboss.weld.event.ObserverMethodImpl.sendEvent(ObserverMethodImpl.java:265)
	at org.jboss.weld.event.ObserverMethodImpl.notify(ObserverMethodImpl.java:234)
	at org.jboss.weld.manager.BeanManagerImpl.notifyObservers(BeanManagerImpl.java:635)
	at org.jboss.weld.manager.BeanManagerImpl.fireEvent(BeanManagerImpl.java:622)
	at org.jboss.weld.manager.BeanManagerImpl.fireEvent(BeanManagerImpl.java:616)
	at org.jboss.forge.shell.Bootstrap$1.run(Bootstrap.java:186)
	at java.lang.Thread.run(Thread.java:744)
Caused by: com.openshift.client.OpenShiftEndpointException: Could not request /api: javax.net.ssl.SSLProtocolException: handshake alert:  unrecognized_name
	at com.openshift.internal.client.RestService.request(RestService.java:103)
	at com.openshift.internal.client.RestService.request(RestService.java:91)
	at com.openshift.internal.client.RestService.request(RestService.java:72)
	at com.openshift.internal.client.AbstractOpenShiftConnectionFactory.getConnection(AbstractOpenShiftConnectionFactory.java:34)
	at com.openshift.client.OpenShiftConnectionFactory.getConnection(OpenShiftConnectionFactory.java:134)
	at com.openshift.client.OpenShiftConnectionFactory.getConnection(OpenShiftConnectionFactory.java:104)
	at com.redhat.openshift.core.OpenShiftServiceFactory.create(OpenShiftServiceFactory.java:17)
	at com.redhat.openshift.forge.OpenShiftFacet.internalInstall(OpenShiftFacet.java:101)
	at com.redhat.openshift.forge.OpenShiftFacet.install(OpenShiftFacet.java:81)
	... 66 more
Caused by: com.openshift.internal.client.httpclient.HttpClientException: javax.net.ssl.SSLProtocolException: handshake alert:  unrecognized_name
	at com.openshift.internal.client.httpclient.UrlConnectionHttpClient.createException(UrlConnectionHttpClient.java:191)
	at com.openshift.internal.client.httpclient.UrlConnectionHttpClient.get(UrlConnectionHttpClient.java:96)
	at com.openshift.internal.client.RestService.request(RestService.java:139)
	at com.openshift.internal.client.RestService.request(RestService.java:97)
	... 74 more
Caused by: javax.net.ssl.SSLProtocolException: handshake alert:  unrecognized_name
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:526)
	at sun.net.www.protocol.http.HttpURLConnection$6.run(HttpURLConnection.java:1675)
	at sun.net.www.protocol.http.HttpURLConnection$6.run(HttpURLConnection.java:1673)
	at java.security.AccessController.doPrivileged(Native Method)
	at sun.net.www.protocol.http.HttpURLConnection.getChainedException(HttpURLConnection.java:1671)
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1244)
	at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:468)
	at sun.net.www.protocol.https.HttpsURLConnectionImpl.getResponseCode(HttpsURLConnectionImpl.java:338)
	at com.openshift.internal.client.httpclient.UrlConnectionHttpClient.createException(UrlConnectionHttpClient.java:174)
	... 77 more
Caused by: javax.net.ssl.SSLProtocolException: handshake alert:  unrecognized_name
	at sun.security.ssl.ClientHandshaker.handshakeAlert(ClientHandshaker.java:1292)
	at sun.security.ssl.SSLSocketImpl.recvAlert(SSLSocketImpl.java:1952)
	at sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:1077)
	at sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1312)
	at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1339)
	at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1323)
	at sun.net.www.protocol.https.HttpsClient.afterConnect(HttpsClient.java:563)
	at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:185)
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1300)
	at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:254)
	at com.openshift.internal.client.httpclient.UrlConnectionHttpClient.get(UrlConnectionHttpClient.java:91)
	... 76 more
Comment 8 Andre Dietisheim 2013-11-28 09:06:54 EST
The latter SSL error is not related to this bugzilla. This error is caused by a "bad" SSL cert as found in OpenShift Devenvs where the SSL cert wont match the host name. The consequence is that the JDK is throwing an exception complaining about "unrecognized_name". See https://bugzilla.redhat.com/show_bug.cgi?id=970805, https://bugzilla.redhat.com/show_bug.cgi?id=973219 and https://www.openshift.com/forums/openshift/ssl-handshake-alert-unrecognizedname-error#comment-31316 for more details. 
To avoid this error, you have to add the following when launching your jvm:

-Djsse.enableSNIExtension=false
Comment 9 XiuJuan Wang 2013-11-29 04:49:45 EST
Hi,Andre,
According to your information, I have resloved the SSL error with java7, but the
"unknow request parameter type integer" was still there, with following env. Thanks!

devenv_4083
java version "1.7.0_45"
openshift 1.0.6.final
forge 1.4.3.final
Comment 10 Andre Dietisheim 2013-11-29 05:10:45 EST
I'm very sure that the error would go away if forge upgraded to the latest openshift-java-client.
Comment 11 Jessica Forrester 2014-07-11 14:54:06 EDT
Andre, has forge upgraded to the latest client at this point, if not when can we expect that?
Comment 12 Andre Dietisheim 2014-07-11 21:13:21 EDT
Hi Jessica

I cant tell you, I'm not in charge of Forge. I suggest that you ping the Forge team about it.
I only do the openshift-java-client that they use.
Comment 13 yyuan 2014-12-19 03:22:55 EST
Forge 1.4.4.Final
Java Version 1.7.0
Openshift plugin 1.0.6.Final
ose 2.2.3 

 "unknow request parameter type integer" error still exists 

[forge-openshift-demo] forge-openshift-demo $ rhc setup 
***INFO*** Loaded OpenShift configuration from /home/yyuan/.openshift/express.conf
 ? Enter the application name [forgeopenshiftd]  [forgeopenshiftd] 
***INFO*** Using RHLOGIN:yanywang for https://broker.ose22-manual.com.cn
 ? Enter your Red Hat Openshift password: ******
java.lang.RuntimeException: com.openshift.client.OpenShiftRequestException: Unknow request parameter type integer
	at com.redhat.openshift.forge.OpenShiftFacet.install(OpenShiftFacet.java:86)
	at org.jboss.forge.project.BaseProject.performInstallation(BaseProject.java:240)
	at org.jboss.forge.project.BaseProject.installFacet(BaseProject.java:166)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.jboss.weld.bean.proxy.AbstractBeanInstance.invoke(AbstractBeanInstance.java:48)
	at org.jboss.weld.bean.proxy.ProxyMethodHandler.invoke(ProxyMethodHandler.java:125)
	at org.jboss.weld.proxies.Project$-1946286523$Proxy$_$$_WeldClientProxy.installFacet(Project$-1946286523$Proxy$_$$_WeldClientProxy.java)
	at org.jboss.forge.shell.project.FacetInstallationHandler.performInstallation(FacetInstallationHandler.java:105)
	at org.jboss.forge.shell.project.FacetInstallationHandler.install(FacetInstallationHandler.java:81)
	at org.jboss.forge.shell.project.FacetInstallationHandler.installRequest(FacetInstallationHandler.java:59)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.jboss.weld.util.reflection.SecureReflections$13.work(SecureReflections.java:305)
	at org.jboss.weld.util.reflection.SecureReflectionAccess.run(SecureReflectionAccess.java:54)
	at org.jboss.weld.util.reflection.SecureReflectionAccess.runAsInvocation(SecureReflectionAccess.java:163)
	at org.jboss.weld.util.reflection.SecureReflections.invoke(SecureReflections.java:299)
	at org.jboss.weld.introspector.jlr.WeldMethodImpl.invokeOnInstance(WeldMethodImpl.java:188)
	at org.jboss.weld.introspector.ForwardingWeldMethod.invokeOnInstance(ForwardingWeldMethod.java:59)
	at org.jboss.weld.injection.MethodInjectionPoint.invokeOnInstanceWithSpecialValue(MethodInjectionPoint.java:198)
	at org.jboss.weld.event.ObserverMethodImpl.sendEvent(ObserverMethodImpl.java:282)
	at org.jboss.weld.event.ObserverMethodImpl.sendEvent(ObserverMethodImpl.java:265)
	at org.jboss.weld.event.ObserverMethodImpl.notify(ObserverMethodImpl.java:234)
	at org.jboss.weld.manager.BeanManagerImpl.notifyObservers(BeanManagerImpl.java:635)
	at org.jboss.weld.manager.BeanManagerImpl.fireEvent(BeanManagerImpl.java:628)
	at org.jboss.weld.event.EventImpl.fire(EventImpl.java:75)
	at com.redhat.openshift.forge.OpenShiftPlugin.setup(OpenShiftPlugin.java:100)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.jboss.forge.shell.command.Execution.perform(Execution.java:160)
	at org.jboss.forge.shell.command.fshparser.FSHRuntime.run(FSHRuntime.java:109)
	at org.jboss.forge.shell.command.fshparser.FSHRuntime.run(FSHRuntime.java:47)
	at org.jboss.forge.shell.ShellImpl$ExecutorThread.run(ShellImpl.java:796)
	at org.jboss.forge.shell.ShellImpl.execute(ShellImpl.java:819)
	at org.jboss.forge.shell.ShellImpl.doShell(ShellImpl.java:609)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.jboss.weld.bean.proxy.AbstractBeanInstance.invoke(AbstractBeanInstance.java:48)
	at org.jboss.weld.bean.proxy.ProxyMethodHandler.invoke(ProxyMethodHandler.java:125)
	at org.jboss.forge.shell.ShellImpl$Proxy$_$$_WeldClientProxy.doShell(ShellImpl$Proxy$_$$_WeldClientProxy.java)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.jboss.weld.util.reflection.SecureReflections$13.work(SecureReflections.java:305)
	at org.jboss.weld.util.reflection.SecureReflectionAccess.run(SecureReflectionAccess.java:54)
	at org.jboss.weld.util.reflection.SecureReflectionAccess.runAsInvocation(SecureReflectionAccess.java:163)
	at org.jboss.weld.util.reflection.SecureReflections.invoke(SecureReflections.java:299)
	at org.jboss.weld.introspector.jlr.WeldMethodImpl.invokeOnInstance(WeldMethodImpl.java:188)
	at org.jboss.weld.introspector.ForwardingWeldMethod.invokeOnInstance(ForwardingWeldMethod.java:59)
	at org.jboss.weld.injection.MethodInjectionPoint.invokeOnInstanceWithSpecialValue(MethodInjectionPoint.java:198)
	at org.jboss.weld.event.ObserverMethodImpl.sendEvent(ObserverMethodImpl.java:282)
	at org.jboss.weld.event.ObserverMethodImpl.sendEvent(ObserverMethodImpl.java:265)
	at org.jboss.weld.event.ObserverMethodImpl.notify(ObserverMethodImpl.java:234)
	at org.jboss.weld.manager.BeanManagerImpl.notifyObservers(BeanManagerImpl.java:635)
	at org.jboss.weld.manager.BeanManagerImpl.fireEvent(BeanManagerImpl.java:622)
	at org.jboss.weld.manager.BeanManagerImpl.fireEvent(BeanManagerImpl.java:616)
	at org.jboss.forge.shell.Bootstrap$1.run(Bootstrap.java:186)
	at java.lang.Thread.run(Thread.java:745)
Caused by: com.openshift.client.OpenShiftRequestException: Unknow request parameter type integer
	at com.openshift.internal.client.response.LinkParameterType.valueOfIgnoreCase(LinkParameterType.java:30)
	at com.openshift.internal.client.response.LinkParameter.<init>(LinkParameter.java:32)
	at com.openshift.internal.client.response.ResourceDTOFactory.createLinkParameter(ResourceDTOFactory.java:566)
	at com.openshift.internal.client.response.ResourceDTOFactory.createLinkParameters(ResourceDTOFactory.java:547)
	at com.openshift.internal.client.response.ResourceDTOFactory.createLinks(ResourceDTOFactory.java:276)
	at com.openshift.internal.client.response.ResourceDTOFactory.createApplication(ResourceDTOFactory.java:383)
	at com.openshift.internal.client.response.ResourceDTOFactory.createApplications(ResourceDTOFactory.java:353)
	at com.openshift.internal.client.response.ResourceDTOFactory.get(ResourceDTOFactory.java:113)
	at com.openshift.internal.client.RestService.request(RestService.java:92)
	at com.openshift.internal.client.RestService.request(RestService.java:76)
	at com.openshift.internal.client.AbstractOpenShiftResource$ServiceRequest.execute(AbstractOpenShiftResource.java:137)
	at com.openshift.internal.client.DomainResource.loadApplications(DomainResource.java:200)
	at com.openshift.internal.client.DomainResource.getOrLoadApplications(DomainResource.java:186)
	at com.openshift.internal.client.DomainResource.getApplications(DomainResource.java:192)
	at com.openshift.internal.client.DomainResource.getApplicationByName(DomainResource.java:145)
	at com.openshift.internal.client.DomainResource.hasApplicationByName(DomainResource.java:140)
	at com.redhat.openshift.forge.OpenShiftFacet.internalInstall(OpenShiftFacet.java:116)
	at com.redhat.openshift.forge.OpenShiftFacet.install(OpenShiftFacet.java:81)
	... 66 more
Comment 14 Wenjing Zheng 2015-03-04 21:51:06 EST
(In reply to Andre Dietisheim from comment #12)
> Hi Jessica
> 
> I cant tell you, I'm not in charge of Forge. I suggest that you ping the
> Forge team about it.
> I only do the openshift-java-client that they use.

According to the email from George Gastaldi <ggastald@redhat.com>:
Given the 'rhc' tools have improved significantly, and the quickstart
experience on openshift is pretty decent, joined with the great support
in JBoss Developer Studio, we decided to drop support on the Openshift
plugin, since we felt it is no longer useful and also given that we
don't have enough resources to keep it up with the latest Openshift
enhancements.

This bug will no be fixed in Forge, so could you please close it as won't fix? Thanks very much!

Note You need to log in before you can comment on or make changes to this bug.