Bug 1020285 - tgtd: segfault at 0 ip (null) sp 00007fff5324f138 error 14 in tgtd[400000+3e000
tgtd: segfault at 0 ip (null) sp 00007fff5324f138 error 14 in tgtd[400000+3e000
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: scsi-target-utils (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Andy Grover
Bruno Goncalves
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 07:40 EDT by Bruno Goncalves
Modified: 2015-10-09 08:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-09 08:44:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Goncalves 2013-10-17 07:40:18 EDT
Description of problem:
Trying to configure tgtd to use /dev/sd* device with bs-type of rdwr leads to segfaul when initiator tries to login to session.

I don't know if this option should be supported or not, if not tgtd should report an error and not start. 


cat /etc/tgt/targets.conf
default-driver iscsi
<target iqn.2009-10.com.redhat:storage-1>
write-cache off
allow-in-use yes
<backing-store /dev/sdb>
scsi_sn 1553011
scsi_id 1553011
lun 1
bs-type rdwr
device-type pt
</backing-store>
</target>

---- Initiator side ----------
iscsiadm -m discovery -I default -p 127.0.0.1 -t st
Starting iscsid: [ OK ]
127.0.0.1:3260,1 iqn.2009-10.com.redhat:storage-1

iscsiadm -m node -l (tgtd crashes here)

------- Target side ---------
kernel: tgtd[18690]: segfault at 0 ip (null) sp 00007fff5324f138 error 14 in tgtd[400000+3e000 

Version-Release number of selected component (if applicable):
kernel: 2.6.32-422.el6
scsi-target-utils-1.0.24-10.el6


How reproducible:
100%

Steps to Reproduce:
1.Configure tgtd target

2.start tgtd service

3.Discover iSCSI target

4.Login to iSCSI session

5.Check for segfault message on target.
Comment 1 Bruno Goncalves 2013-10-17 07:40:44 EDT
This is also reproducible on RHEL-6.4
Comment 2 Bruno Goncalves 2015-10-09 08:44:04 EDT
It seems to be already fixed on RHEL-6.7 (scsi-target-utils-1.0.24-16.el6)

# cat /etc/tgt/targets.conf
default-driver iscsi
<target iqn.2009-10.com.redhat:storage-1>
write-cache off
allow-in-use yes
<backing-store /dev/sdb>
scsi_sn 1553011
scsi_id 1553011
lun 1
bs-type rdwr
device-type pt
</backing-store>
</target>


# service tgtd start
Starting SCSI target daemon: [  OK  ]
tgtadm: invalid request
Command:
	tgtadm -C 0 --lld iscsi --op new --mode logicalunit --tid 1 --lun 1 -b /dev/sdb --device-type pt --bstype rdwr 
exited with code: 22.

Note You need to log in before you can comment on or make changes to this bug.