Bug 1020316 - websocket proxy configuration is not offered when /etc/pki/ovirt-engine directory already exists
websocket proxy configuration is not offered when /etc/pki/ovirt-engine direc...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Alon Bar-Lev
Pavel Stehlik
integration
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 08:33 EDT by David Jaša
Modified: 2013-10-25 06:07 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-19 15:40:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2013-10-17 08:33:45 EDT
Description of problem:
websocket proxy configuration is not offered when /etc/pki/ovirt-engine directory already exists

Version-Release number of selected component (if applicable):
is19 / rhevm-setup-3.3.0-0.26.master.el6ev.noarch

How reproducible:
always

Steps to Reproduce:
1. copy a working ovirt-engine pki directory (e.g. from previous or different setup) to /etc/pki/ovirt-engine, make sure that permissions/selinux labels are correct
2. run engine-setup
3.

Actual results:
websocket proxy configuration is not offered

Expected results:
websocket proxy configuration should be offered

Additional info:
Comment 1 Alon Bar-Lev 2013-10-19 15:40:24 EDT
If /etc/pki/ovirt-engine/keys/websocket-proxy.p12 exists, the assumption is that websocket is configured either manually or by setup.

So no need to re-configure it, hence no prompt.

Copying blindly files from one setup to another setup is not something that is expected during normal course of application handling.

Closing it as not a bug as it is per design.

Thanks!
Comment 2 David Jaša 2013-10-25 06:04:47 EDT
(In reply to Alon Bar-Lev from comment #1)
> If /etc/pki/ovirt-engine/keys/websocket-proxy.p12 exists, the assumption is
> that websocket is configured either manually or by setup.
> 
> So no need to re-configure it, hence no prompt.
> 

IMO there should be a log message similar to PKI - saying something about websocket proxy configuration being found and assumption that it works.

> Copying blindly files from one setup to another setup is not something that
> is expected during normal course of application handling.
> 

I wanted to achieve just a fresh installation with just PKI (CA) reused. If I understand correctly, this "blind copying of [PKI] files" is also part of backup/restore (that adds also database backup/restore).
Comment 3 Alon Bar-Lev 2013-10-25 06:07:32 EDT
(In reply to David Jaša from comment #2)
> > Copying blindly files from one setup to another setup is not something that
> > is expected during normal course of application handling.
> > 
> 
> I wanted to achieve just a fresh installation with just PKI (CA) reused. If
> I understand correctly, this "blind copying of [PKI] files" is also part of
> backup/restore (that adds also database backup/restore).

backup/restore is taking a backup of one machine and restore it to another including configuration and database.

when you restore configured webproxy you get configured web proxy.

Note You need to log in before you can comment on or make changes to this bug.