Bug 1020327 - samba 4.1.0, the new glusterfs vfs plug-in isn't built
samba 4.1.0, the new glusterfs vfs plug-in isn't built
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Guenther Deschner
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1020329
  Show dependency treegraph
 
Reported: 2013-10-17 09:03 EDT by Kaleb KEITHLEY
Modified: 2013-11-25 23:09 EST (History)
6 users (show)

See Also:
Fixed In Version: samba-4.1.1-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1020329 (view as bug list)
Environment:
Last Closed: 2013-11-25 23:09:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaleb KEITHLEY 2013-10-17 09:03:04 EDT
Description of problem:

samba-4.1.0 includes glusterfs vfs plug-in but it's not built due to missing BuildRequires

Version-Release number of selected component (if applicable):

samba 4.1.0


Additional info:


*** SPECS/samba.spec.orig	2013-10-17 08:22:43.050000000 -0400
--- SPECS/samba.spec	2013-10-17 09:01:44.474000000 -0400
***************
*** 122,127 ****
--- 122,130 ----
  BuildRequires: sed
  BuildRequires: zlib-devel >= 1.2.3
  BuildRequires: libbsd-devel
+ BuildRequires: glusterfs-api-devel
+ BuildRequires: glusterfs-devel
+ Requires: glusterfs-api
  
  %if ! %with_internal_talloc
  %global libtalloc_version 2.0.7
***************
*** 743,748 ****
--- 746,752 ----
  %{_libdir}/samba/vfs/fake_perms.so
  %{_libdir}/samba/vfs/fileid.so
  %{_libdir}/samba/vfs/full_audit.so
+ %{_libdir}/samba/vfs/glusterfs.so
  %{_libdir}/samba/vfs/linux_xfs_sgid.so
  %{_libdir}/samba/vfs/media_harmony.so
  %{_libdir}/samba/vfs/netatalk.so
***************
*** 1488,1493 ****
--- 1492,1500 ----
  %{_mandir}/man8/pam_winbind.8*
  
  %changelog
+ * Thu Oct 17 2013 - Kaleb S. KEITHLEY <kkeithle at redhat.com> 
+ - build glusterfs vfs
+ 
  * Fri Oct 11 2013 - Andreas Schneider <asn@redhat.com> - 4.1.0-1
  - related: #985609 - Update to Samba 4.1.0.
Comment 1 Fedora Update System 2013-11-11 08:14:44 EST
samba-4.1.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/samba-4.1.1-1.fc20
Comment 2 Fedora Update System 2013-11-11 19:29:37 EST
Package samba-4.1.1-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing samba-4.1.1-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21088/samba-4.1.1-1.fc20
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2013-11-25 23:09:52 EST
samba-4.1.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.