Bug 1020328 - Human task assigned to analyst group does not appear in the task list
Human task assigned to analyst group does not appear in the task list
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high
: ER5
: 6.0.0
Assigned To: Mauricio Salatino
Jan Hrcek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 09:04 EDT by Jan Hrcek
Modified: 2014-08-06 16:09 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Summary: Creating a group name that is the same as a role name will cause that group to be inaccessible for task assignments for Human tasks. At the moment, there are only two roles: analyst and admin, and group names should not be same as these. In a future release, role names will be expanded to include developer, user and manager and you should avoid using these as group names as well. When you want to have a human task, that you want to be assigned to users based on their membership in some group, you need to avoid group names: analyst, developer Cause: Consequence: Fix: Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:09:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Steps to reproduce - video (9.53 MB, video/webm)
2013-10-17 09:04 EDT, Jan Hrcek
no flags Details
Simple process to reproduce the problem (8.33 KB, application/xml)
2013-10-17 09:05 EDT, Jan Hrcek
no flags Details

  None (edit)
Description Jan Hrcek 2013-10-17 09:04:23 EDT
Created attachment 813317 [details]
Steps to reproduce - video

Description of problem:
The task, that has assignment defined only for a group does not appear in the task list. This worked correctly in BPMS ER3, but no longer works in ER4.

See videos attached for steps to reproduce (process attached)



Version-Release number of selected component (if applicable):
BPMS 6.0.0 ER4

How reproducible:
Always

Steps to Reproduce:
1. I have a simple process (start -> Human Task -> end) with human task assignment defined for group analyst only.
2. Deploy project with this process, start one instance of this process.
3. Go to task list.

Actual results:
The task from the process is not visible in the task list (it was visible there in ER3, but is NOT visible in ER4)

Expected results:
Since my user is member of the group for which the assignment of human task is defined, the task list must contains the task for that user.
Comment 1 Jan Hrcek 2013-10-17 09:05:01 EDT
Created attachment 813318 [details]
Simple process to reproduce the problem
Comment 2 Mauricio Salatino 2013-10-18 06:40:49 EDT
I couldn't reproduce this issue with 6.0.x. This was already solved there by solving another issue with the task lists and the filter. Can you please re try in your build and let me know, so I can identify if further modifications are needed
Comment 3 Mauricio Salatino 2013-10-21 11:41:39 EDT
You need to make sure that the group exist and it doesn't match a role, there are a set of roles that will be excluded for the name of the groups for tasks:
I think that in this case analyst is a role and not a group, and for that reason you cannot assign a task for that group. 
I've found this commit which is basically doing that: https://github.com/droolsjbpm/jbpm/commit/89cea706c19f1f5a1d5d03ec06e623167e657639

We have two restricted groups names that right now are reserved for roles: developers, analyst.
All the restricted groups in that file will not be created as groups in the human task service.
Comment 4 Jan Hrcek 2013-10-23 03:37:24 EDT
Yes, you're right. In my process definition I used analyst as group in the human task. After I changed the HT in the process to use my custom defined group, the group task is assigned correctly and is visible in the task list. So it's working even in BPMS 6.0.0 ER4

But this definitely needs to be documented. To reiterate for doc team:
When you want to have a human task, that you want to be assigned to users based on their membership in some group, you need to avoid group names: analyst, developer (more groups are likely to be added later - see https://bugzilla.redhat.com/show_bug.cgi?id=1022253)
Comment 5 Maciej Swiderski 2013-10-23 13:11:10 EDT
slightly modified and only admin role is restricted group in ht meaning it will not be used for ht assignments whatsoever. For HT there is Administrators group that is strictly used for business administrators of a task.

jbpm-console-ng
master
https://github.com/droolsjbpm/jbpm-console-ng/commit/0f4de3a3c73c1600f3a9f18d84e753a3c921c718

6.0.x
https://github.com/droolsjbpm/jbpm-console-ng/commit/d0b7ada84ff1ad16a052de128c3dd94ce4487d44

kie-wb
master
https://github.com/droolsjbpm/kie-wb-distributions/commit/4fec1111d8b0e03f6f2daddf260bd90431cdfbae

6.0.x
https://github.com/droolsjbpm/kie-wb-distributions/commit/d31e4d5add04863c37adc9a0a759dde316a355b8
Comment 6 Jan Hrcek 2013-12-02 02:40:20 EST
Ok, now users in analyst group can see human tasks assigned to analyst group. Verified with BPMS 6.0.0 ER5

Note You need to log in before you can comment on or make changes to this bug.