Bug 102033 - hang on rebuild
hang on rebuild
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: coreutils (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-09 05:48 EDT by Michael Redinger
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version: 4.5.3-26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-17 06:54:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Redinger 2003-08-09 05:48:47 EDT
There is a strange problem when trying to rebuild the 
coreutils-4.5.3-22.src.rpm package on Taroon. The rebuild process always 
hangs. It is always the same test that fails for me. 100% reproduceable.
I just do not know who is to blame ...

The last thing printed by rpmbuild --rebuild [srpm] is:

make[2]: Entering directory 
`/usr/local/es/taroon/RedHat/BUILD/coreutils-4.5.3/tests/stty'
make  check-TESTS
make[3]: Entering directory 
`/usr/local/es/taroon/RedHat/BUILD/coreutils-4.5.3/tests/stty'
PASS: row-col-1



When doing a ps auxwww I see the following process:

stty 
400:5:bf:8a31:3:1c:7f:15:4:0:1:0:11:13:1a:0:12:f:17:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0


Attaching with strace -c ... to it results in the following output:

--- SIGSTOP (Stopped (signal)) @ 0 (0) ---
--- SIGSTOP (Stopped (signal)) @ 0 (0) ---
ioctl(0, SNDCTL_TMR_STOP, {B38400 opost isig -icanon -echo ...}) = ? 
ERESTARTSYS (To be restarted)
--- SIGTTOU (Stopped (tty output)) @ 0 (0) ---
--- SIGTTOU (Stopped (tty output)) @ 0 (0) ---
ioctl(0, SNDCTL_TMR_STOP, {B38400 opost isig -icanon -echo ...}) = ? 
ERESTARTSYS (To be restarted)
--- SIGTTOU (Stopped (tty output)) @ 0 (0) ---
--- SIGTTOU (Stopped (tty output)) @ 0 (0) ---
ioctl(0, SNDCTL_TMR_STOP, {B38400 opost isig -icanon -echo ...}) = ? 
ERESTARTSYS (To be restarted)
--- SIGTTOU (Stopped (tty output)) @ 0 (0) ---
--- SIGTTOU (Stopped (tty output)) @ 0 (0) ---
Comment 1 Michael Redinger 2003-08-09 05:50:56 EDT
Should have noted that the SNDCTL_TMR_STOP ... SIGTTOU messages keep repeating 
forever.

This is a Dell PowerEdge 2400 dual-processor server (SMP kernel).
Comment 2 Michael Redinger 2003-08-09 11:56:37 EDT
This is actually something different and definitely not a coreutils problem ...


*** This bug has been marked as a duplicate of 102042 ***
Comment 3 Michael Redinger 2003-08-10 07:33:33 EDT
In bug #102042 (similar problem with zsh) Roland McGrath notes that it is not a
kernel but an app problem. Therefore changing back to coreutils again, removing
resoved duplicate.
Comment 4 Jens Petersen 2003-09-17 06:52:33 EDT
I assume Michail forgot to reopen this.
Comment 5 Jens Petersen 2003-09-17 06:54:38 EDT
Oops, sorry, I guess it was already fixed.

Note You need to log in before you can comment on or make changes to this bug.