Bug 1020344 - Power Managent with cisco_ucs problem
Power Managent with cisco_ucs problem
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
3.3
x86_64 Linux
urgent Severity urgent
: ---
: 3.3.3
Assigned To: Eli Mesika
bugs@ovirt.org
infra
:
Depends On: 1014513
Blocks: 996978 1040875
  Show dependency treegraph
 
Reported: 2013-10-17 09:27 EDT by Dael Maselli
Modified: 2014-02-14 04:57 EST (History)
9 users (show)

See Also:
Fixed In Version: ovirt-3.3.3-beta1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1040875 (view as bug list)
Environment:
Last Closed: 2014-02-14 04:57:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Compiled form and error bottom. (42.76 KB, image/png)
2013-10-17 09:27 EDT, Dael Maselli
no flags Details
CISCO UCS PM works (31.60 KB, image/png)
2013-10-22 07:52 EDT, Eli Mesika
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 22311 None None None Never

  None (edit)
Description Dael Maselli 2013-10-17 09:27:09 EDT
Created attachment 813333 [details]
Compiled form and error bottom.

Description of problem:
No way to configure cisco_ucs Power Management for Host.

Version-Release number of selected component (if applicable):
ovirt-engine-3.3.0-4.el6.noarch
vdsm-4.12.1-2.el6.x86_64

How reproducible:
Configure cisco_ucs as power management for a host.


Steps to Reproduce:
1. Edit host
2. In Power Management select cisco_ucs and compile form (as attachment)
3. click "Test"


Actual results:
Ignoring unknown option '=Linux1'
Failed: You have to enter plug number
Please use '-h' for usage

Expected results:
Test success


Additional info:

With old version 3.2 it works well.

/var/log/ovirt-engine/engine.log:

2013-10-17 12:35:58,964 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ajp--127.0.0.1-8702-7) Correlation ID: null, Call Stack: null, Custom Event ID: -1, Message: Host ovc1n02.lnf.infn.it from cluster CiscoBlades was choosen as a proxy to execute Status command on Host ovc1n01.lnf.infn.it.
2013-10-17 12:35:58,965 INFO  [org.ovirt.engine.core.bll.FenceExecutor] (ajp--127.0.0.1-8702-7) Using Host ovc1n02.lnf.infn.it from cluster CiscoBlades as proxy to execute Status command on Host
2013-10-17 12:35:58,987 INFO  [org.ovirt.engine.core.bll.FenceExecutor] (ajp--127.0.0.1-8702-7) Executing <Status> Power Management command, Proxy Host:ovc1n02.lnf.infn.it, Agent:cisco_ucs, Target Host:, Management IP:ucs.lnf.infn.it, User:ovc1mgr_user, Options:secure=true,slot=Linux1
2013-10-17 12:35:59,010 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.FenceVdsVDSCommand] (ajp--127.0.0.1-8702-7) START, FenceVdsVDSCommand(HostName = ovc1n02.lnf.infn.it, HostId = 62cefcce-2637-4321-a78f-fa04a7927fde, targetVdsId = 1f1efda1-7e8f-4141-8720-182faa86113f, action = Status, ip = ucs.lnf.infn.it, port = , type = cisco_ucs, user = ovc1mgr_user, password = ******, options = 'secure=true,slot=Linux1'), log id: 4c92e476
2013-10-17 12:35:59,011 ERROR [org.ovirt.engine.core.utils.pm.VdsFenceOptions] (ajp--127.0.0.1-8702-7) Cannot find fence agent named cisco_ucs in fence option mapping
2013-10-17 12:35:59,011 ERROR [org.ovirt.engine.core.utils.pm.VdsFenceOptions] (ajp--127.0.0.1-8702-7) Cannot find fence agent named cisco_ucs in fence option mapping
2013-10-17 12:35:59,115 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ajp--127.0.0.1-8702-7) Correlation ID: null, Call Stack: null, Custom Event ID: -1, Message: Power Management test failed for Host ovc1n01.lnf.infn.it.Parse error: Ignoring unknown option '=Linux1'
Failed: You have to enter plug number
Please use '-h' for usage

2013-10-17 12:35:59,116 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.FenceVdsVDSCommand] (ajp--127.0.0.1-8702-7) FINISH, FenceVdsVDSCommand, return: Test Failed, Parse error: Ignoring unknown option '=Linux1'
Failed: You have to enter plug number
Please use '-h' for usage
, log id: 4c92e476
Comment 1 Dael Maselli 2013-10-17 09:33:05 EDT
Passing parameters on cmdline and stdin directly to fence_cisco_ucs works:

[root@ovc1n02 ~]# fence_cisco_ucs --action=status --ip=ucs.lnf.infn.it --username=ovc1mgr_user --password=******** -z --plug=Linux1
Status: ON

[root@ovc1n02 ~]# fence_cisco_ucs
action=status
ipaddr=ucs.lnf.infn.it
login=ovc1mgr_user
passwd=*********
ssl=yes
port=Linux1
^D
Status: ON
Comment 2 Dan Kenigsberg 2013-10-17 12:42:46 EDT
Could you attach the fenceNode command from vdsm.log? I suspect that you might have a typo in your "additional options field", or there's an Engine bug leading to"

Ignoring unknown option '=Linux1'
Failed: You have to enter plug number
Please use '-h' for usage
Comment 3 Dael Maselli 2013-10-18 04:30:30 EDT
Thread-29261::DEBUG::2013-10-17 12:35:59,131::API::1109::vds::(fenceNode) fenceNode(addr=ucs.lnf.infn.it,port=,agent=cisco_ucs,user=ovc1mgr_user,passwd=XXXX,action=status,secure=,options==Linux1)
Thread-29261::DEBUG::2013-10-17 12:35:59,167::API::1135::vds::(fenceNode) rc 1 in agent=fence_cisco_ucs
ipaddr=ucs.lnf.infn.it
login=ovc1mgr_user
option=status
passwd=XXXX
=Linux1 out  err Parse error: Ignoring unknown option '=Linux1'
Failed: You have to enter plug number
Please use '-h' for usage

I attached the screenshot of the configuration where you can see there is no additional equal sign.
Comment 4 Dan Kenigsberg 2013-10-18 07:54:02 EDT
Oh dear, it seems that Engine sends your "Slot" as an auxiliary option instead of using the (badly named) "port" argument.
Comment 5 Dael Maselli 2013-10-21 05:12:52 EDT
Just for the record: Updated to 3.3.0.1-1.el6, same behavior.
Comment 6 Eli Mesika 2013-10-22 07:51:52 EDT
unable to reproduce (see attachment)
Comment 7 Eli Mesika 2013-10-22 07:52:55 EDT
Created attachment 814950 [details]
CISCO UCS PM works
Comment 8 Eli Mesika 2013-10-22 08:29:51 EDT
(In reply to Eli Mesika from comment #6)
> unable to reproduce (see attachment)

The only chage I see between the original image attached to the bug description and the one attached in comment 7 is that in the original there is a SSH Port in the UI (That should not be there) while in the  comment 7 this field is missing.

I suspect that this may be related to https://bugzilla.redhat.com/show_bug.cgi?id=1014513 

Note that this bug reported that VdsFenceOptionMapping value was not retrieved with the cluster version, rather, the UI tried to get this value with 'general' version and since there is no such value in DB it got the static value from the ConfigValues.java class :

alom:secure=secure,port=ipport;
apc:secure=secure,port=ipport,slot=port;bladecenter:secure=secure,port=ipport,slot=port;
drac5:secure=secure,port=ipport;
eps:slot=port;ilo:secure=ssl,port=ipport;
ipmilan:;
rsa:secure=secure,port=ipport;
rsb:;
wti:secure=secure,port=ipport,slot=port

Also note that there is no value for cisco_ucs here, so UI preserves the latest selected valid agent fields

should be tested again with the above BZ fix and if the assumption above is correct, I will close that as a duplicate of 1014513
Comment 9 Dael Maselli 2013-10-31 05:58:07 EDT
I'm sorry but I can't understand what should I do.
Comment 10 Eli Mesika 2013-11-19 07:40:49 EST
should be tested again when 3.3.2 is available (Nov 27 AFAIK)
Comment 11 Sandro Bonazzola 2013-11-28 10:34:04 EST
Re-targeting to 3.3.3 since the bug is not resolved in 3.3.2 beta and is not blocking 3.3.2 release tracker (bug #1027349)
Comment 12 Sandro Bonazzola 2014-02-14 04:57:07 EST
Closing as 3.3.3 has been released.

Note You need to log in before you can comment on or make changes to this bug.