Bug 1020353 - Process is saved even if I just close it
Process is saved even if I just close it
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high
: ER5
: 6.0.0
Assigned To: Tihomir Surdilovic
Sona Mala
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 09:48 EDT by Sona Mala
Modified: 2014-08-06 16:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Summary: In the Project Authoring view, trying to discard changes made to a new Process in the Designer by pressing the close (X) button actually saves the changes. Cause: Consequence: Fix: Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:10:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Video file - step to reproduce (3.23 MB, video/webm)
2013-10-18 01:45 EDT, Sona Mala
no flags Details
test_reproduce_video (1.02 MB, video/quicktime)
2013-10-18 12:00 EDT, Tihomir Surdilovic
no flags Details

  None (edit)
Description Sona Mala 2013-10-17 09:48:21 EDT
Description of problem:
Process is saved even if I just close it by button "X" in the right top corner.


Version-Release number of selected component (if applicable):
6.0.0 BPMS ER4

How reproducible:


Steps to Reproduce:
1. create new process
2. append task (make some changes)
3. close (without press button "Save")
4. reopen process

Actual results:
Process contains changes.

Expected results:
Designer should discard unsaved changed.


Additional info:
This is TestBlocker because our tests expect some initial state of process (elements type, propertie's values etc.) which is saved in our repository and any test never saves result of its work and just closes it.
Now there is problem, the first test leaves a process in incompatible state.
Comment 1 Tihomir Surdilovic 2013-10-17 11:35:31 EDT
I cannot reproduce this behavior locally. Designer was updated to ask user if they would like to save unsaved changes ( http://i.imgur.com/Km4HNht.png ) . I suspect that maybe you did not clear the browser cache before testing. Please retest and let me know.

Thanks.
Comment 2 Kris Verlaenen 2013-10-17 12:28:52 EDT
Tiho, could reproduce this on CR4 with kie-wb, so might already be solved? please recheck
Comment 3 Tihomir Surdilovic 2013-10-17 13:10:12 EDT
I have tested with Designer 6.0.x branch and cannot reproduce it either. Will try CR4 now.
Comment 4 Sona Mala 2013-10-18 01:45:54 EDT
Created attachment 813603 [details]
Video file - step to reproduce

I test it again with our product version (ER4 BPMS) on browser FF and Chrome.
How you can see in an attached video, I deleted a cache and cookies.

There is only one alert "Business Process may contain unsaved changes. Are you sure you would like to close the editor?". Same alert which was appended by Tiho in comment #1.

And I am pretty sure that I want to close the editor and discard all changes in process. If I reopen process I want to see just one start node. How you can see in video this's not happen. The process contains three nodes instead of one.

Some other applications shows this alert:
"Business Process may contain unsaved changes. Do you want to save changes before you close this editor?"
and options are:
  - YES -> save process and close editor
  - NO -> discard changes and close editor (this option is missing)
  - CANCEL -> close an alert (user can continue in his work)
Comment 6 Marek Baluch 2013-10-18 02:54:12 EDT
Tiho - IMO it will be better if you try the product instead. Many times stuff works on community versions but not on product versions.

http://dev138.mw.lab.eng.bos.redhat.com/candidate/bpms-6.0.0-ER4/
Comment 7 Tihomir Surdilovic 2013-10-18 12:00:19 EDT
I created a movie using ER4 your linked and it seems to work OK (attached savebz.mov). One thing I don't know how to do really is have a new repository I cloned show in the File Explorer so I can test with a new asset as well, but it should be the exact same code as when opening existing asset like shown in my movie. 

Thanks.
Comment 8 Tihomir Surdilovic 2013-10-18 12:00:56 EDT
Created attachment 813830 [details]
test_reproduce_video
Comment 9 Tihomir Surdilovic 2013-10-18 12:38:25 EDT
Update - the video I created was from the Administration view where this issue does not happen. From the Project Authoring view this issue DOES happen as described. Looking into this.
Comment 10 Tihomir Surdilovic 2013-10-18 15:09:23 EDT
I have added an update to the designer 6.0.x branch. Would it be possible to test this out on your end quickly? If I try to replace the designer-* jars in ER5 with ones i build from the 6.0.x branch things break so I'm not really sure how to put my update into ER4 and try to test it out.
Let me know.

Thanks.
Comment 11 Tihomir Surdilovic 2013-10-18 18:19:53 EDT
I tested the change on kie-wb and it seems this is resolved. Commit https://github.com/droolsjbpm/jbpm-designer/commit/c535c8609be05b09af5aa0f3646ceb723f0e4c20

I will put issue as modified so it can be tested on your end as well.

Thanks.
Comment 12 Marek Baluch 2013-11-27 14:16:00 EST
Verified on ER5.

When I choose to discard the changes (by selecting OK) then they will not be there after I open the process the second time.

Note You need to log in before you can comment on or make changes to this bug.