Bug 1020363 - Horizon fails to function due to an ImportError
Horizon fails to function due to an ImportError
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
4.0
Unspecified Linux
unspecified Severity urgent
: beta
: 4.0
Assigned To: Matthias Runge
Nir Magnezi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 10:10 EDT by Nir Magnezi
Modified: 2013-12-19 19:29 EST (History)
6 users (show)

See Also:
Fixed In Version: python-django-horizon-2013.2-1.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:29:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2013:1859 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2013-12-20 19:01:48 EST

  None (edit)
Description Nir Magnezi 2013-10-17 10:10:34 EDT
Description of problem:
=======================
Via packstack, I installed Horizon as a standalone node.
It fails to function due to an ImportError.

Version-Release number of selected component (if applicable):
=============================================================
puddle: 2013-10-15.1
python-django-horizon-2013.2-0.15.rc2.el6ost.noarch

How reproducible:
=================
1/1

Steps to Reproduce:
===================
1. Install OpenStack via packstack, Make sure that the node you configure to run Horizon is only used with  CONFIG_HORIZON_HOST.
2. Try to login.
3.


Actual results:
===============
At first, I got internal server error.
I restarted httpd and tried to browse horizon once again.

Login failed with the following errors:
ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.path?): No module named eventlet    


Expected results:
=================
Horizon should function properly.
Comment 4 Nir Magnezi 2013-11-11 09:08:33 EST
Verified NVR: python-django-horizon-2013.2-3.el6ost.noarch

Followed the 'Steps to Reproduce' in Comment #0
Result: Horizon works with no errors.
Comment 7 errata-xmlrpc 2013-12-19 19:29:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.