Bug 1020366 - redhat6 sudo over sssd doesn't work : libsss_sudo missing
redhat6 sudo over sssd doesn't work : libsss_sudo missing
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd (Show other bugs)
6.6
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jakub Hrozek
Kaushik Banerjee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 10:17 EDT by guillard
Modified: 2013-10-17 11:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 11:13:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description guillard 2013-10-17 10:17:54 EDT
Description of problem:

when configuring to instruct sudo to gather sudo rules
over sssd, I get the folowing error message :

# sudo ls /etc/sssd

sudo: Unable to dlopen /usr/lib64/libsss_sudo.so: (null)
sudo: Unable to initialize SSS source. Is SSSD installed on your machine?


Version-Release number of selected component (if applicable):

sssd-1.9.2-82.7.el6_4.x86_64

How reproducible:

Steps to Reproduce:
1. yum install sssd sudo sssd-client pam nss
2. echo "sudoers:   sss files" >> /etc/nsswitch.conf
3. add appropriate "sudo_provider" and "ldap_sudo_search_base" to sssd.conf
4. add "sudo" to "services =" in sssd.conf
5. echo "[sudo]" >> /etc/sssd/sssd.conf

Actual results:

sudo: Unable to dlopen /usr/lib64/libsss_sudo.so: (null)

Expected results:

grant access based on sudo rules found in sssd

Additional info:

To fix this bug, download and install libsss_sudo (from
rpmfind for example : tested with libsss_sudo-1.9.2-82.10).


Normally, libsss_sudo should be packaged within redhat
sudo package.
Comment 2 Jakub Hrozek 2013-10-17 11:13:31 EDT
In RHEL6, you need to install libsss_sudo yourself, in later releases we moved the library back to the SSSD itself.

Not a bug, sorry for the inconvenience.

Note You need to log in before you can comment on or make changes to this bug.