Bug 1020372 - regression in event deregistration
regression in event deregistration
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.5
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Martin Kletzander
Virtualization Bugs
: Regression, ZStream
Depends On:
Blocks: 1020376 1038814
  Show dependency treegraph
 
Reported: 2013-10-17 10:33 EDT by Eric Blake
Modified: 2016-04-26 11:42 EDT (History)
9 users (show)

See Also:
Fixed In Version: libvirt-0.10.2-30.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1020376 (view as bug list)
Environment:
Last Closed: 2014-10-14 00:17:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Blake 2013-10-17 10:33:31 EDT
Description of problem:
Quoting from upstream:

> When I quit the process which only register VIR_DOMAIN_EVENT_ID_REBOOT, I got error like:
> "libvirt: XML-RPC error : internal error: domain event 0 not registered".

Version-Release number of selected component (if applicable):
all libvirt builds based on 0.9.9 and later

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
https://www.redhat.com/archives/libvir-list/2013-October/msg00798.html
Comment 1 Eric Blake 2013-10-17 10:42:45 EDT
RHEL 6.3 was first release with the regression
Comment 7 yanbing du 2014-04-13 23:15:54 EDT
Following the verify steps in https://bugzilla.redhat.com/show_bug.cgi?id=1020376#c5 
1. Repreduce this bug with libvirt-0.10.2-29.el6.x86_64:
# ./test 

^CExiting on signal 2

myFreeFunc: Freeing [cb1]
libvir: XML-RPC error : internal error domain event 0 not registered

2. verify bug with libvirt-0.10.2-31.el6.x86_64:

# ./test 
^CExiting on signal 2

myFreeFunc: Freeing [cb1]
Comment 9 errata-xmlrpc 2014-10-14 00:17:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1374.html

Note You need to log in before you can comment on or make changes to this bug.