Bug 1020417 - ssh_config manual page lists incorrect default value of KexAlgorithms
ssh_config manual page lists incorrect default value of KexAlgorithms
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides (Show other bugs)
6.5
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Peter Schiffer
Iveta Wiedermann
: ManPageChange, Patch
Depends On:
Blocks: 1023043
  Show dependency treegraph
 
Reported: 2013-10-17 11:50 EDT by Lukas "krteknet" Novy
Modified: 2014-02-18 18:57 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: ssh_config(5) manual page contained incorrect default value for KexAlgorithms option Consequence: incorrect documentation Fix: correct default value for KexAlgorithms option on ssh_config(5) manual page Result: correct documentation
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 17:59:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixed ssh_config.5 (33.34 KB, application/x-troff-man)
2013-10-18 09:07 EDT, Petr Lautrbach
no flags Details

  None (edit)
Description Lukas "krteknet" Novy 2013-10-17 11:50:33 EDT
Description of problem:
Manual page of ssh_config contains:
     KexAlgorithms
             Specifies the available KEX (Key Exchange) algorithms.  Multiple algorithms must be comma-separated.  The default
             is “ecdh-sha2-nistp256”, “ecdh-sha2-nistp384”, “ecdh-sha2-nistp521”, “diffie-hellman-group-exchange-sha256”,
             “diffie-hellman-group-exchange-sha1”, “diffie-hellman-group14-sha1”, “diffie-hellman-group1-sha1”.

This is wrong as “ecdh-sha2-nistp256”, “ecdh-sha2-nistp384” and “ecdh-sha2-nistp521” are not implemented by RH's openssh.

Version-Release number of selected component (if applicable):
openssh-client-5.3p1-93.el6

How reproducible:
Always

Steps to Reproduce:
1. man ssh_config | grep ecdh-sha2-nistp256 || echo OK

Actual results:
             “ecdh-sha2-nistp256”, “ecdh-sha2-nistp384”, “ecdh-sha2-nistp521”,


Expected results:
OK

Additional info:
Comment 3 Petr Lautrbach 2013-10-18 09:07:35 EDT
Created attachment 813770 [details]
fixed ssh_config.5

--- a/ssh_config.5
+++ b/ssh_config.5
@@ -633,9 +633,6 @@ and
 Specifies the available KEX (Key Exchange) algorithms.
 Multiple algorithms must be comma-separated.
 The default is
-.Dq ecdh-sha2-nistp256 ,
-.Dq ecdh-sha2-nistp384 ,
-.Dq ecdh-sha2-nistp521 ,
 .Dq diffie-hellman-group-exchange-sha256 , 
 .Dq diffie-hellman-group-exchange-sha1 ,
 .Dq diffie-hellman-group14-sha1 ,
Comment 4 RHEL Product and Program Management 2013-10-24 08:36:12 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 12 errata-xmlrpc 2013-11-21 17:59:25 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1695.html

Note You need to log in before you can comment on or make changes to this bug.