Bug 1020432 - Fix man page for ssh-keygen because of certificate support
Fix man page for ssh-keygen because of certificate support
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Peter Schiffer
Iveta Wiedermann
: ManPageChange, Patch
Depends On:
Blocks: 1023044
  Show dependency treegraph
 
Reported: 2013-10-17 12:12 EDT by Miroslav Vadkerti
Modified: 2013-11-21 17:59 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: "-n" option in ssh-keygen(1) program was renamed to "-Z" option, but ssh-keygen(1) manual page was not updated Consequence: incorrect documentation Fix: update ssh-keygen(1) manual page Result: correct documentation
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 17:59:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixed ssh-keygen.1 (20.55 KB, application/x-troff-man)
2013-10-18 05:05 EDT, Petr Lautrbach
no flags Details

  None (edit)
Description Miroslav Vadkerti 2013-10-17 12:12:26 EDT
Description of problem:
Bug 906872 - certificate support in OpenSSH introduced a feature but the ssh-keygen man page was not adjusted correctly. The upstream provided -n option has been changed to -Z as the original is already used by our downstream patch. This needs to be properly documented in our version of man page. Without this our patch bring in an undocumented option and the usability of the feature becomes limited.

Version-Release number of selected component (if applicable):
openssh-5.3p1-94.el6

How reproducible:
100%

Steps to Reproduce:
1. man ssh-keygen, check -n and -Z documentation

Actual results:
no -Z documentation

Expected results:
Properly documented -Z option for passing principal list
Comment 1 Petr Lautrbach 2013-10-18 05:05:41 EDT
Created attachment 813656 [details]
fixed ssh-keygen.1

diff --git a/ssh-keygen.1 b/ssh-keygen.1
index fa520d4..8dfa302 100644
--- a/ssh-keygen.1
+++ b/ssh-keygen.1
@@ -113,7 +113,7 @@
 .Fl s Ar ca_key
 .Fl I Ar certificate_identity
 .Op Fl h
-.Op Fl n Ar principals
+.Op Fl Z Ar principals
 .Op Fl O Ar option
 .Op Fl V Ar validity_interval
 .Op Fl z Ar serial_number
@@ -300,7 +300,7 @@ candidate moduli for DH-GEX.
 Extract the public key from smartcard.
 .It Fl N Ar new_passphrase
 Provides the new passphrase.
-.It Fl n Ar principals
+.It Fl Z Ar principals
 Specify one or more principals (user or host names) to be included in
 a certificate when signing a key.
 Multiple principals may be specified, separated by commas.
@@ -549,8 +549,8 @@ names.
 By default, generated certificates are valid for all users or hosts.
 To generate a certificate for a specified set of principals:
 .Pp
-.Dl $ ssh-keygen -s ca_key -I key_id -n user1,user2 user_key.pub
-.Dl "$ ssh-keygen -s ca_key -I key_id -h -n host.domain user_key.pub"
+.Dl $ ssh-keygen -s ca_key -I key_id -Z user1,user2 user_key.pub
+.Dl "$ ssh-keygen -s ca_key -I key_id -h -Z host.domain user_key.pub"
 .Pp
 Additional limitations on the validity and use of user certificates may
 be specified through certificate options.
Comment 2 RHEL Product and Program Management 2013-10-24 04:08:05 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 10 errata-xmlrpc 2013-11-21 17:59:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1695.html

Note You need to log in before you can comment on or make changes to this bug.