Bug 1020463 - Error adding new content to an existing content view
Error adding new content to an existing content view
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.4
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Brad Buckingham
Sachin Ghai
: Triaged
: 1021394 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 13:36 EDT by Mike McCune
Modified: 2014-04-24 13:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:09:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
First I added 'fake' and 'puppet1' repos and later updated the CV with new repo 'fake1' (49.38 KB, image/png)
2013-10-22 06:49 EDT, Sachin Ghai
no flags Details

  None (edit)
Description Mike McCune 2013-10-17 13:36:15 EDT
1) Create a content view with some repos

2) Publish it

3) Add a new repo to a product, sync it

4) Go back to your CV from step 1 and add this new repo

Note error:

 can't convert Fixnum into Array (TypeError)
   Click here for more details.
Comment 1 Brad Buckingham 2013-10-17 13:42:39 EDT
I was able to repro on dev w/ the following:

1. create product1 with repo1 (yum)
2. create product2 with repo1 (yum)
3. create product3 with repo1 (puppet)
4. create a content view definition
5. add product1 repo1 (yum) and product3 repo1 (puppet) to the definition

6. attempt to add product2 with repo1 (yum)

boom...error...
Comment 3 Brad Buckingham 2013-10-17 14:00:51 EDT
katello pull request:

https://github.com/Katello/katello/pull/3205
Comment 6 Dominic Cleal 2013-10-22 06:03:45 EDT
*** Bug 1021394 has been marked as a duplicate of this bug. ***
Comment 7 Sachin Ghai 2013-10-22 06:46:04 EDT
Verified with MDP2 Snap6 Compose3.

[root@HOST201-143 ~]# rpm -qa | grep katello
katello-1.4.6-44.el6sat.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-configure-1.4.7-7.el6sat.noarch
katello-glue-elasticsearch-1.4.6-44.el6sat.noarch
katello-foreman-all-1.4.6-44.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
ruby193-rubygem-foreman-katello-engine-0.0.17-6.el6sat.noarch
katello-common-1.4.6-44.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
katello-configure-foreman-1.4.7-7.el6sat.noarch
katello-cli-1.4.3-26.el6sat.noarch
katello-certs-tools-1.4.4-1.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-glue-pulp-1.4.6-44.el6sat.noarch
katello-glue-candlepin-1.4.6-44.el6sat.noarch
katello-cli-common-1.4.3-26.el6sat.noarch
katello-all-1.4.6-44.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-4.el6sat.noarch
signo-katello-0.0.23-2.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.12-3.el6sat.noarch

The reported issue is no longer reproducible with this build. I can add new content to existing content-view as per comment1.
Comment 8 Sachin Ghai 2013-10-22 06:49:00 EDT
Created attachment 814930 [details]
First I added 'fake' and 'puppet1' repos and later updated the CV with new repo 'fake1'
Comment 9 Bryan Kearney 2014-04-24 13:09:27 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 10 Bryan Kearney 2014-04-24 13:10:57 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.