Bug 1020479 - packstack not allowing hostname in CONFIG_CINDER_GLUSTER_MOUNTS
packstack not allowing hostname in CONFIG_CINDER_GLUSTER_MOUNTS
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
4.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 4.0
Assigned To: Ivan Chavero
Nir Magnezi
: OtherQA, Triaged
Depends On:
Blocks: 1040649
  Show dependency treegraph
 
Reported: 2013-10-17 14:19 EDT by Steve Reichard
Modified: 2016-04-26 09:35 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.14.dev919.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:29:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 56545 None None None Never

  None (edit)
Description Steve Reichard 2013-10-17 14:19:23 EDT
Description of problem:

While I appreciate the gluster mount configuration in packstack my first attempt to use it failed because I used a hostname (no IP) in the mount specification:

Parameter CONFIG_CINDER_GLUSTER_MOUNTS failed validation: Given value does not match required regular expression: 'ra-rhs-srv1-10g.storage.se.priv:/OSTACKcinder'

ERROR : Failed handling answer file: Given value does not match required regular expression: 'ra-rhs-srv1-10g.storage.se.priv:/OSTACKcinder'

Switch to an IP number was successful.

Version-Release number of selected component (if applicable):


[root@cvd1 ~]# yum list installed | grep -i openstack
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
openstack-packstack.noarch     2013.2.1-0.6.dev763.el6ost
                                                  @OpenStack-4.0-Puddle         
[root@cvd1 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.5 Beta (Santiago)
[root@cvd1 ~]# uname -r
2.6.32-419.el6.x86_64
[root@cvd1 ~]# 





How reproducible:

I was able to easily reproduce to get teh error for this BZ.


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 3 Scott Lewis 2013-12-09 10:30:46 EST
Adding OtherQA for bugs in MODIFIED
Comment 6 Ivan Chavero 2013-12-15 17:08:06 EST
Successfully tested functionality on:
openstack-packstack.noarch            2013.2.1-0.18.dev934.el6ost
Comment 8 errata-xmlrpc 2013-12-19 19:29:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.