Bug 1020516 - Cannot build cython and numpy while using python-2.7 cartridge
Cannot build cython and numpy while using python-2.7 cartridge
Status: CLOSED ERRATA
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Rob Millner
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 15:55 EDT by Rob Millner
Modified: 2015-05-14 19:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 16:55:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Millner 2013-10-17 15:55:15 EDT
Description of problem:
Cannot build cython or numpy for python 2.7 cartridge.  Cannot find the development headers/libraries.

But if I create an account, set up a virtual environment for it that's similar to the cartridge install, then I can build both cython and numpy.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a python 2.7 application
2. edit setup.py and add cython
  install_requires=['cython'],

3. commit & push

Actual results:
Build fails

Expected results:
Build succeeds


Additional info:

It may be worth adding Cython (apache license) and NumPy RPMs.  We add NumPY already to python 2.6, just not the 2.7 or 3.3 SCL.
Comment 1 Rob Millner 2013-10-17 16:09:35 EDT
Turns out the problem doesn't affect cython, just numpy.  Numpy will be provided via RPM for python-2.7 shortly so setting this low severity.

I still want to see why the build environment is different.

Note You need to log in before you can comment on or make changes to this bug.