Bug 102052 - please consider updating to 1.99.17
please consider updating to 1.99.17
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux Beta
Classification: Retired
Component: pygtk2 (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-09 16:46 EDT by Jon Willeke
Modified: 2007-04-18 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-02 09:12:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Willeke 2003-08-09 16:46:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4) Gecko/20030804
Epiphany/0.8.2

Description of problem:
I see that severn includes PyGTK 1.99.16.  1.99.17 has since been released with
an important new feature: custom widget support.  GLADE can include widgets in a
project that it doesn't directly support (e.g., ZVT or VTE), by calling a
user-specified widget creation routine.

A patch in GNOME bug 113271 adds a set_custom_widget_callbacks() function to the
gtk.glade module.  This is now available in PyGTK 1.99.17, which is supposed to
be the final release before 2.0.

I have been happily using 1.99.17 since its release.

Version-Release number of selected component (if applicable):
pygtk2-1.99.16-6

How reproducible:
Always

Steps to Reproduce:
In a terminal with DISPLAY set, issue the following statements in a Python session:

>>> import gtk.glade
>>> gtk.glade.set_custom_widget_callbacks( locals() )

Actual Results:  AttributeError: 'module' object has no attribute
'set_custom_widget_callbacks'

Expected Results:  successful call

Additional info:
Note that 1.99.17 omits "module" from the name of the .so files in
/usr/lib/python2.2/site-packages/gtk-2.0/gtk, so glademodule.so is now glade.so.
Comment 1 Dave Habben 2003-09-27 17:38:13 EDT
The version that comes with Beta 2 is now:
 pygtk2-2.0.0-1

Can this bug be closed?
Comment 2 Jon Willeke 2003-10-02 09:12:14 EDT
PyGTK 2.0.0 deprecated the set_custom_widget_callbacks() function introduced in
1.99.17.  Use set_custom_handler(), instead.

While I haven't tested beta 2, I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.