Bug 102053 - Config files need attention
Config files need attention
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-09 17:25 EDT by Andrew E. Mileski
Modified: 2007-04-18 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-09 17:54:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew E. Mileski 2003-08-09 17:25:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

Description of problem:
The i686 configuration file (configs/linux-2.4.20-i686.config) needs attention.

It appears that it was made long ago by hand (order and organization hint
towards this) and has been lightly adjusted as each new kernel came out, instead
of regenerated with kernel configuration utilities for each kernel.  Since it
was put together in this manner, it contains a few oddities:
  - possibly no longer supported config options
  - possibly a device driver for which the bus driver is not built
  - missing "standard" config options generated by config tools
  - drivers that aren't selected when all similar ones are (missed? conflict?)

I won't detail these, as I'm sure you are well aware going through them all is
quite tedious (several hours of work).  The only reason I'm going through them
myself is to generate a Red Hat-ish custom kernel rpm for re-distribution to
better support my laptop and other systems (includes latest ACPI patch).

I recommend generating new config files, say via "make xconfig", then adding in
any special options (removing generated options isn't recommended) for each new
kernel.

Feel free to mark this bug closed.

Version-Release number of selected component (if applicable):
2.4.20-8

Additional info:
I suspect the other config files need an attention too.
Comment 1 Arjan van de Ven 2003-08-09 17:54:28 EDT
actually the config files are generated from a central database via automated
tooling; most of this database is generic for all the kernels we do with minor
delta's for specific kernels. The result of this is that the .config files have
options that may not exist for all kernels, but that is not a problem. "make
oldconfig" will just ignore such settings.
You will also possibly see settings that are dependent on other settings, which
aren't set. That also is a result of the tooling; some versions may have that
higher level setting on and then suddenly the lower level ones become relevant.

Note You need to log in before you can comment on or make changes to this bug.